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How to Use This Manual 
This guide (focusing on ODOT configuration and customization) is intended as a reference for 
InRoads users migrating from InRoads XM (v8.9) to InRoads V8i SS2 (v8.11).  In this guide, file or 
folder names may be recommended; please use the following substitutions:  keynu = project key 
number (5 digit numeric value), myname = your name (first or last or both). 

The guide is organized by first discussing more general topics that affect the overall configuration of 
the software.  After that, the topics follow the InRoads menu choices from left to right and top to 
bottom.  Workflows for typical ODOT procedures are at the very end because I saved the best… 

Launching InRoads 

ODOT>InRoads Lite 

In MicroStation, the ODOT menu has been modified to offer choices based upon the software 
that is loaded on your computer.  The ODOT menu inside MicroStation V8i may be used to 
launch a lighter version of InRoads V8i without additional applications like Bentley Map.  Other 
Bentley Products, such as InRoads Survey or InRoads Storm and Sanitary, may be opened after 
launching InRoads Lite by selecting TOOLS > PRODUCT ADD-INS… from the InRoads Explorer.  
InRoads Lite is sufficient for most of your vertical design needs, from annotating plan view 
graphics and cutting profiles to creating alignments and running the Roadway Modeler. 

 

InRoads Desktop Shortcut 

InRoads V8i may also be launched from a desktop shortcut or the Start button.  If you primarily 
use InRoads Survey or InRoads Storm & Sanitary, you may find it easiest to launch InRoads with 
an additional product already loaded using a shortcut in the All Programs group under the Start 
button. You may use FILE > OPEN or FILE > NEW in MicroStation to change or create a design 
file or use Model Manager to change or create models, without exiting InRoads.   

When you launch InRoads V8i from the desktop shortcut or Windows Start button, additional 
tools are available to use. An Applications menu will appear on the MicroStation menu bar from 
which you may choose InRoads tools or Activate Bentley Map. Other tools that are available are 
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Civil Geometry and Roundabouts tasks that can be enabled on the MicroStation ODOT menu. 
The tasks may be docked and unpinned to appear as tabs.  You may also right click on the tasks 
and open the tools as a toolbox. Data Acquisition will appear in the MicroStation Tools menu. 

 

 
Tip! The ODOT mdl is required for many drafting tools including the Bubble tools and 
Leader macros. If you have launched InRoads from a desktop shortcut instead of just 
MicroStation, you will receive errors and those commands will not run. 

“Unknown key-in or command” or “Execution failed at line 168. Error: 1702” 

It might be easiest to exit InRoads, then launch just MicroStation and if you need 
InRoads, launch it using ODOT>InRoads Lite. Alternatively, a key-in can be used leaving 
InRoads running and can be assigned to a function key. Key in: mdl load odot.  

Working Offline 
After launching InRoads V8i on the network one time, you may work offline for 30 days.  Use the 
Offline_Workspace shortcut in the Engineering desktop folder prior to going offline, to copy an 
ODOT workspace and your user configuration files to your laptop.  Data files must be manually 
copied from your Engineering Personal Server Share (F:\ drive) to a laptop for use in the field. 

 

Tools > Data Acquisition 

Civil Geometry and 

Roundabouts  

toolboxes 

Civil Geometry and 

Roundabouts tasks 
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While working off line, you may get an “Activation Status” dialog that pops up and counts down 
for you how long you have to connect to a network and launch InRoads while online to get a 
new license.  Dismiss the dialog by clicking the [Try It] button. 

File Locations 

InRoads files in the workspace (odot_space\V8i) 

Files that are used by InRoads Storm & Sanitary are stored on workspace servers in 
…\odot_space\V8i\Standards\data\InRoads\StmSan. 

The StmSan sub-folder contains the V8i_ORstructures.dat, which InRoads Storm & Sanitary will 
use from this location, and it also contains all of the IDF files for the Oregon zones.  In order to 
be used, the IDF file for your project’s zone should be copied into the project directory that 
contains the working design file. 

A shortcut in the Engineering folder on your desktop can be used to access the StmSan folder.  
Double-click on the ODOT_DGN_seed_files shortcut to open a “Windows Explorer” dialog.  Click 
on the Standards folder in the Address bar, then drill down into the data\InRoads\StmSan 
folder. 
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InRoads files in F:\ODOT_DATA\USERCFG\InRoads 

Files that are used by InRoads to provide preferences and symbologies are stored in your 
engineering personal server share, F:\ODOT_DATA\USERSCFG\InRoads.  The InRoads 
preference file, civil.xin, is refreshed with each logon so that you always have access to the 
current standards.  When working offline, the files are found in 
C:\ProgramData\odot_space\USERCFG\InRoads after using the Offline_Workspace shortcut; 
they are delivered to consultants in the ODOT workspace that can be downloaded from ODOT’s 
ftp site. 

XIN - The civil.xin file may be copied into your project folder and will retain project specific 
customizations after that.  If you copy civil.xin into a project folder, it is recommended that you 
rename the file to keynu.xin. 

ITL - ODOTseed.itl is intended to be copied into your project folder and renamed keynu.itl. 

A shortcut in the Engineering folder on your desktop can be used to access the ITL or XIN files.  
Double-click on the ODOT_User_Configuration shortcut to open a “Windows Explorer” dialog.  
Then, open the InRoads folder. 

Click on the Desktop 
favorite, and then open 
the Engineering folder. 

Double-click on the 
ODOT_DGN_seed_files 
shortcut. 

Click on Standards, then 
drill down into data. 
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File Translation 

Surfaces (.dtm) 

Surface files created in version 7 through version 8.9 can be opened with InRoads V8i. They will 
automatically be converted upon saving.   When operating InRoads V8i, you will NOT be 
informed, through status bar messages or pop-ups, that you have loaded a surface from a 
previous version.  You will NOT be warned when saving the surface that you may be overwriting 
a previous version with a newer version that is not compatible with InRoads XM.  It is 
recommended that you name version 8.9 surface filenames (keynu_XM.dtm) and surfacenames 
(keynu_XM) using as an indicator to you that the file is specific to version 8.9.  For example, 
filename = 01234e_XM.dtm, surfacename = 01234e_XM. 

Save surfaces for use in version 8.9 (XM) using FILE > SAVE AS…, select Save as type: Surfaces 

(*.dtm), then set the compatibility to Version 8.7 to 8.11.5 Compatible using the [Options…] 
button.  Again, it is recommended to save the filename using the version as part of the file 
name. 

Surfaces in version 8.4 and above include a preference assigned to control plan view display of 
triangles, contours, etc.; and named symbology assigned to define profile and cross section 
surface line display. When importing a previously created surface a default preference and 
symbology will automatically be assigned.  

Geometry Projects (.alg) 
Geometry project (alignment) files created in version 7 through version 8.9 can be opened in 
InRoads V8i.  They will automatically be converted upon saving.  When operating InRoads V8i, 
you will NOT be informed, through status bar messages or pop-ups, that you have loaded an 
alignment from a previous version.  You will NOT be warned when saving the geometry project 
that you may be overwriting a previous version with a newer version that is not compatible with 
v8.9 (XM) InRoads.  It is recommended that you name version 8.9 alignment filenames 
(keynu_XM.alg) and geometry projects (keynu_XM) using XM as an indicator to you that the file 
is specific to version 8.9.  For example, filename = 01234_XM.alg, geometry project name = 
01234_XM. 
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Save alignments for use in version 8.9 (XM) using FILE > SAVE AS…, select Save as type: 
Geometry Projects (*.alg), then set the compatibility to Version 8.7/8.8/8.9 Compatible using 
the [Options…] button.  Again, it is recommended to save the filename using the version as part 
of the name. 

Known Geometry Issues 

V8i to XM (.alg) Conversion 

When InRoads is exited, all changes to loaded .alg files are saved.  When InRoads creates a 
new .alg file using File>Save As, the new file (XM) is automatically loaded and converted to 
V8i on-the-fly.  The on-the-fly translation is normally a good thing, but in this case, it has 
just loaded the XM file you created, converted it back to V8i, and when you exit InRoads, 
your XM version .alg will be written over with V8i version. 

The way to preserve your XM version of the .alg is to not have it loaded when you exit.  
The following procedure takes you through one method of accomplishing this. 

 

1. Click File>Save As… 

or right-click on the 

geometry project and 

choose Save As… 
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Note which geometry project file is now loaded – it is the one you just saved!  Now use 
Windows Explorer and the drag and drop technique to load the .alg file you began with.  
Hint:  It is not in a “2XM” folder.  Loading another file like this prevents InRoads from 
saving and overwriting the XM version in the 2XM folder with a V8i version.  It also leaves 
the designer ready to move on with the V8i .alg loaded.  Version XM geometry projects 
(.alg) can now be found in the 2XM folder, if needed. 

Cannot Load a Read-Only.ALG 

When you attempt to open a geometry project (.alg), whether the file attribute is set to 
read-only or you are attempting to load a geometry project file from another’s 
F:\ODOT_DATA\Projects folder structure, InRoads will report “Error writing to file” and 
will not load the geometry project. 

2. Create a new 

folder, eg. 2XM, and 

open it. 

3. Click the Options… 

button and select 

“Version 8.7/8.8/8.9 

Compatible”, then Save. 
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The workaround to this issue is to ensure that the geometry project is in a location where 
you have write access and that the file is not set to read-only.  This may mean copying the 
.alg file from someone else’s F:\ODOT_DATA\Projects folder structure and saving it in your 
own. 

Access Mode is Read-Only, not Read-Write 

When the Access Mode for alignments is set to Read-Only, changes cannot be made to 
the alignments.  The alignments may also be locked by another user which can prevent 
you from changing your access from Read-Only to Read-Write.  Alignments may be locked 
by another user when .alg files are loaded or copied from a shared location.  When the 
.alg file is loaded initially, InRoads checks to see if the alignments are locked for use by 
another person and displays an Access Mode of Read-Only for you if they are.  If the .alg 
file is copied while it is loaded (and locked) by another person, it is copied in a locked state 
and the alignment access modes will still report Read-Only for you.  If you are working 
with a shared .alg file on a server or in ProjectWise, please refer to the section on Access 
Control of Geometry and the InRoads Help for changing your access mode. 

If you are working in a copy of an .alg file and you wish to make alignments locked by 
another user Read-Write, take the following steps.  Load the copy of the .alg file into 
InRoads.  Right-click on the Geometry Project name in the InRoads Explorer Workspace 
Bar and choose DETAILS…  In the “Access Control Details” dialog, select all alignments 
using click and <Shift>+click, then hold down the <Ctrl> key and click the [Free] button.  
Select all the alignments again and click [Check Out].  Save the .alg file, overwriting your 
copy.  These steps, if followed exactly, will unlock access by another user and allow you to 
make the Access Mode for all of the alignments and the cogo buffer Read-Write. 

Template Libraries (.itl) 
A template library seed file (.itl) has been created for ODOT use.  It is named ODOTseed.itl and is 
stored in the F:\ODOT_DATA\USERCFG\InRoads folder.  It is recommended that you copy the 
ODOTseed.itl file, save it in your project directory, and rename it keynu.itl. 
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The template libraries are written in XML format and you can get some fairly decent reports of 
your templates using the Report Browser (TOOLS > VIEW XML REPORTS…). 

Roadway Design (.ird) 
The roadway design files (.ird) are written in XML format and you can get some fairly decent 
reports of your corridors using the Report Browser (TOOLS > VIEW XML REPORTS…). 

Project Files (.rwk) 

Project files are still just text files.  It’s easy to create new .rwk  files and we recommend that 
you do.  Select FILE > SAVE AS… , select Save As Type: “Projects (*.rwk)”, and click the 
[Options…] button. 

Known Project File Translation Issues 

There are really no translation issues, as a text file is still a text file and the format between 
the versions is the same.  The only issue is that the location of the standard civil.xin has 
changed.  If you have used the full path and have stored the location of the XM version 
standard civil.xin, you should edit the text file in Notepad or NotePad++ and change 
“ENG_APP” to “USERCFG”. 

InRoads Preference Files (.xin) 

InRoads preference files (.xin) created in version 8.9 (XM) can be opened in InRoads V8i, 
although it is not recommended.  The styles and symbologies used for annotating and stationing 
center lines, have all been reconfigured to be used with annotation scale.  The points placed by 
“CL_*” named symbologies are designed to be annotated in a model with a drawing scale of 
1”=100’ and are scaled down by a factor of 1200. 

Known Preference File Translation Issues 

Some of the dialog boxes, especially for the VIEW GEOMETRY commands, have changed quite 
a bit and have additional fields.  If an XM version civil.xin is used to station an alignment, the 
result appears nothing like the ODOT standards for contract plans.  The standard ODOT 
preference file (.xin) has been updated to account for the changes in the commands.  The 
recommendation is to use the new civil.xin in your USERCFG folder.  If you have Styles or 
Named Symbologies that you would like to continue to use in V8i, the COPY PREFERENCES 
tool can be used.  Copying Styles will bring over their associated named symbologies.  You’ll 
have to go to TOOLS>APPLICATION ADD-INS and add it first, then execute the command 
from the TOOLS menu.  You are cautioned to not copy any preference from the VIEW 
GEOMETRY menu. 

 

 
Caution: Do not copy any style beginning with “CL_” from a civil.xin used with InRoads 
XM.  The CL_* styles and their associated named symbologies are designed to function 
differently using InRoads V8i. 
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Preferences 
Every time we perform any operation within InRoads we must choose a preference to define how 
that operation is to be performed.  ODOT’s standard preference file is named civil.xin.  The XIN file 
contains InRoads settings, like locks, named symbologies, styles, and preference sets for dialog box 
entries. 

Within the civil.xin, one of the most encompassing preference sets you will find is the ODOT 
preference set.  The ODOT preference set has initialized settings for more than ¾ of the dialog 
boxes found on InRoads’ menus.  The ODOT preference set will draw plan graphics and annotation 
symbologies similar to contract plans, but places on-board symbols instead of standard cells to make 
the design process of redrawing and annotating graphics more rapid.  An ODOT-Plans preference 
has been created for use in drawing and annotating the design in plan view, using annotation scale 
according to contract plans symbology.  For example, when you use View Stationing to label stations 
on an alignment, there are nine tabs, each with check boxes, radio buttons, drop down menus, and 
symbology settings to make decisions about.  The ODOT-Plans preference set makes all of the 
choices so that the stationing appearance matches the drafting standards for contract plans as 
closely as possible. 

What will InRoads load automatically? 
A batch file, which runs every time you logon, places a fresh civil.xin file in your 
F:\ODOT_DATA\USERCFG\InRoads folder.  The ODOT preference set is the preferred 
preference set and is loaded by default when the InRoads session is launched.   Unless you 
change the Project Defaults, the ODOT preference set will be initially loaded for every 
command.  You may load a different preference set by selecting the [Preferences…] button on 
any dialog. 

Naming Conventions in Civil.xin 

Preference Sets (Dialog Box Settings) 

At one time preference sets were named with the first group of characters defining 
functionality, such as ALG = Geometry related preferences, DTM = Surface related 
preferences, SURV = Survey Filing Map Preferences, etc. The second grouping was used to 
further describe the preferences set. For example, within the DTM preference sets we find 
EXISTING, SUBGRADE, ROCK, and FINISH.  This naming convention was not often 
followed in the past and the result is that the function of a preference set may not be 
readily apparent. 

You may ask, for which dialog boxes do we have preference sets?  There are two ways to 
find that information – use the Preference Manager, or click [Preferences…] from inside a 
dialog box. 

The tabs in the Preference Manager (TOOLS > PREFERENCE MANAGER…) correspond to 
menu items.  You can locate the names of preference sets that are initialized for specific 
commands on each menu by selecting a tab, then selecting a preference set name from the 
pull down list.  (The ODOT preference set is initialized for more commands than any other 
preference set.)  You can quickly shift from tab to tab and find commands for which the 
selected preference set is initialized. 
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If how the preference set is configured is what you’re after, then launch the command from 
the menu and click the [Preferences…] button to discover only the preference sets that are 
initialized for the active dialog box.  It is fairly quick to load several different preference sets 
and compare the values in the fields. 

Styles and Named Symbologies 

Styles and named symbologies have names that consist of several parts separated by 
underbars. (IE: Hy_Pipe_Arch_E) 

The first group of characters define an area of interest, so Br = Bridge Features, Rdwy = 
Roadway Features, Rw = Right of Way Features, Surv = Survey Features, Traf = Traffic 
Features, Util = Utility Features, Xsec = Features in Cross Section, etc.  

Additional character groupings describe the feature. For example, within Utility Features, 
the second group of characters identifies the type of utility such as Elec, Gas, Wtr, etc. 
Subsequent characters further classify the feature. For example Gas_Meter, Wtr_Valve, 

etc.  

The last character denotes whether that feature is E = Existing, or P= Proposed. 

A group of styles and their matching named symbologies begin with MAT- and do not use 
the E or P at the end of the name.  These materials styles were created specifically for use 
with components used in roadway modeling.  When components of a design template are 
assigned an MAT- style, the resulting component from a design surface may be displayed in 
plan view or in cross sections.  The ODOTseed.itl template library contains components with 
MAT- styles correctly assigned.  End-Area volume reports produced after displaying design 
surfaces in cross section rely on the MAT- style setting that allows the components to be 
displayed in the cross section.  See the sections on What’s in ODOTseed.itl and End-Area 
Volume Reports for more information. 

There are 16 styles, described as “Style added for View Horizontal Annotation Point Style”, 
that use similarly named and described symbologies which are initialized for geometry plan 
point display only.  The ODOT preference set uses these styles to place on-board symbols 
(X) at the cardinal points along the alignment when the alignment is viewed using View 
Horizontal Annotation.  See the section on Geometry Styles and Symbologies for more on 
this. 

Additionally, styles were created specifically for the display of features that might be 
commonly displayed or labeled in cross sections – barrier, guardrail, fence, and RW labels.  
Styles beginning with Xsec are based upon the Rdwy or Rw style for that particular 
feature, but have the cross section point defined to place a cell in the cross section as 
opposed to a “plus sign”.  These styles were created for both left (_Lt) and right (_Rt), as 
well as for both proposed (_P) and existing (_E) features.  The cells and labels are pulled 
from XSEC.cel in the workspace.  XSEC.cel contains more cells that could easily be used for 
more styles.  There are a few different kinds of curb cells and labels for EP, as well as 
underground utilities. 

Xsec_Barrier_Lt_E 

Xsec_Barrier_Rt_E 

Xsec_Barrier_Lt_P 
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Xsec_Barrier_Rt_P 

Xsec_Guardrail_Lt_E 

Xsec_Guardrail_Rt_E 

Xsec_Guardrail _Lt_P 

Xsec_Guardrail _Rt_P 

Xsec_Fence_Label_E 

Xsec_RW_Label_E 

Xsec_RW_Label_P 

Xsec_RW_AC_Label_P 

Xsec_RW_PEase_Label_P 

Xsec_RW_TEase_Label_P 

Two styles have been created specifically for transverse features and exterior boundaries.  
Both of the styles place only the lines connecting the points and do not place any point 
symbols at vertices to make it easier to use the graphics drawn by these styles for other 
purposes.  The styles are named Exterior_Boundary and Transverse_Feature and would 
typically be used with the “Import Surface” dialog or the “Create Surfaces” dialog. 

Point Styles are now used for cardinal point placement using the View Active Horizontal.  
The point symbologies have been redefined to place non-standard on board symbols that 
draw and update quickly during alignment edits. 

   

Styles and symbologies used for annotating and stationing center lines for plans have been 
scaled down and are designed to be used with Annotation Scale.  Plan points that are placed 
using any CL_* named symbology are configured for annotating in a model with drawing 
scale of 1”=100’ 

Can I customize my XIN file? 

We encourage you to use the ODOT standard civil.xin for production work.  If you find settings 
that don’t match established drafting standards for contract plans, or find a need for additional 
settings, please submit a change request so that the standard preference file can be improved 
for everyone’s use.  



ODOT InRoads® V8i User Guide 

Page | 20 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

 

 

If you must modify the standard files for special purposes, copy civil.xin from 
F:\ODOT_DATA\USERCFG\InRoads to your desired location.  If the XIN is project specific, well 
then, rename it to keynu.xin.  If the XIN is for your own use with more than one project, you may 
find it easiest to make a copy in F:\ODOT_DATA\USERCFG\InRoads and rename it myname.xin.  
(Bear in mind that you are responsible for managing your custom preference files. Your 
customizations could easily be lost in future releases if you are not careful in how you name 
your files and where you store them.)  Updates to the standard civil.xin will not “magically” 
appear in your customized XIN.  If you wish, it is possible to copy preferences from one XIN into 
another.  COPY PREFERENCES… is an Application Add-In which appears under the TOOLS menu 
after it is added in. 

The preference set named ODOT is set as the preferred set, so ODOT is the set that is used 
when the XIN is loaded. 

 

 
Tip: If you are customizing your preferences, you may find it easier to save your 
changes to the ODOT preference set.  By saving your preferences to the ODOT 
preference set in a custom XIN file, you may save the step of clicking on the 
[Preferences…] button in a dialog and loading another set, because the ODOT 
preference set is loaded initially. 

Variables (Registry) 
InRoads has been customized for ODOT use through the setting of options defined in the current 
user’s computer registry.  The default behavior is set at the time of log on using a logon script file.  
The behavior may be modified during an InRoads session using the “Variable Manager” dialog found 
on the InRoads Tools menu.  The default variable settings are recommended by the InRoads 
Standards Committee and should provide the optimum performance in the ODOT environment. 

InRoads V8i SS2 Refresh 3 provides a variable named “Geometry – Alternate Workflow with 
ProjectWise”, which has been toggled on since the integration with ProjectWise.  The alternate 
workflow allows InRoads to manage the access to individual alignments within the .alg files that are 
stored in a ProjectWise datasource and loaded into InRoads.  The InRoads “Access Control Details” 
dialog is used to check in, check out, update, and free individual alignments instead of the 
ProjectWise “Local Document Organizer” checking in and out the entire .alg file.  When the alternate 
workflow is being used, the .alg file is not checked out of ProjectWise by InRoads and does not 
appear in the “ProjectWise Organizer”. 

Access Control of Geometry 
Access control allows InRoads users to share files among multiple users while controlling Read-Write 
access to the data.  Access control can be used to lock an alignment so that another user cannot 
overwrite it while you are working on it.  Another user can open the data (Read-Only access), but 
cannot make changes to the data while you have it open with Read-Write access.  The reverse is also 
true; if another user has the data open with Read-Write access, you will be able to open it with 
Read-Only access. 

Access Control works in conjunction with your Project Options setting for “Default Access 
Modes” on the Geometry tab, to establish your initial access mode to alignments and the cogo 
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buffer in an .alg file when it is loaded.  Whether or not you have Read-Write or Read-Only access to 
an alignment is dependent upon two things in this order: 

1. If the alignment is currently locked with Read-Write access by another user, then you can 
only be granted Read-Only access to the alignment.  If it’s not locked with Read-Write by 
another user, you will have the ability to be granted Read-Write access depending upon the 
project options. 

2. The project options determine the initial access only when the alignment is not already 
locked with Read-Write access by another user.  If the alignment is available for Read-Write 
access, your default access modes are applied.  If your default access mode is set to Read-
Only, then you are given Read-Only access even when the alignment is not locked with 
Read-Write by another user. 

Regardless of the initial access mode, the access mode may be changed by right-clicking on the 
alignment name or cogo buffer in the workspace bar of the InRoads Explorer and selecting a 
different access mode from the context menu.  In the images below, the “Default Access Mode” is 
set to Read-Only.  The Read-Write access mode is unchecked and grayed out when the alignment or 
cogo buffer is locked in a Read-Write mode by another user. 

   

[Read-Write] will 
perform a [Check Out] 
of the specific 
alignment. 

Grayed-out means not 
available.  Right-click 
geometry project and 
choose [Details…]. 
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In the image on the left, Read-Write is available because no other user has the alignment in Read-
Write access mode.  In the right-hand image, however, another user has the same .alg file loaded 
and is editing the alignment.  If both Read-Write and Read-Only are grayed out, review who has 
access to alignments and the cogo buffer by opening the “Access Control Details” dialog.  Right-
mouse click on the Geometry Project name in the InRoads Explorer Workspace Bar and choose 
Details… 

 

Save new geometry and changes to existing geometry before you open the “Access Controls Details” 
dialog.  Unsaved changes to geometry are discarded when the access mode is changed to Read-only. 

Select [Update] to refresh the access control and use [Check Out] if it is available.  If [Check Out] 
continues to be grayed out after an update, the “Locked By User” column will display the network 
login ID of the user who has Read-Write access. 

When you create new alignments, they are created with the Read-Write status and locked to your 
ID.  When you perform a [Save] on a geometry project, all edits to alignments that you have Read-
Write status to are written to disk and updated in ProjectWise if the .alg file is stored in a 
ProjectWise datasource.  Geometry projects (.alg) stored in ProjectWise and loaded into InRoads are 
not checked out of ProjectWise and do not appear in the “Local Document Organizer”.  InRoads 
pushes changes made to individual alignments back to ProjectWise using the File > Save 
command and [Check In] in the “Access Control Details” dialog. 

In the case of an alignment that is locked by another user, it is possible to force freeing of the 
access.  The alignment could then be checked out with Read-Write access; however, this is not 
recommended in a situation where multiple users are sharing the same .alg file.  In a situation 
where more than one person has Read-Write access at the same time because of a forced free, final 
changes to the shared .alg file will be overwritten by the last user with Read-Write access that saves 
the changes. 

More information about using the “Access Control Details” dialog may be found in the InRoads Help 
documentation. 

  

CL is locked by another user; 
all other alignments are 
Read-Only because of default 
access modes. 
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MicroStation Tools for InRoads Annotation 
An “Add Annotation Scale” tool is provided on an Extra Tools toolbar in MicroStation.  “Add 
Annotation Scale” is intended for use on InRoads annotations (text and cells) to scale them up 
according to the drawing scale of the model and toggle to True the “Is Annotation?” attribute.  The 
“Add Annotation Scale” tool is necessary because InRoads will not apply Annotation Scale to cells or 
text that it places as annotation.  Also included in the Extra Tools is “Remove Annotation Scale”. 

  

 

 

 

[+A] acts on all of the elements in the active model; therefore it is safest to either use InRoads to 
annotate in a new or empty model, or make a selection set of InRoads annotations before clicking 
on the “Add Annotation Scale” button.  Usage of the “Add Annotation Scale” tool will be illustrated 
in the View Geometry section and in a Workflow at the end of the guide. 

  

Add Annotation 

Scale 
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File (menu) 
When working in MicroStation DGN files that are stored in a ProjectWise datasource, any time you 
execute OPEN, SAVE, SAVE AS…, or CLOSE commands from the upper section of the InRoads File 
menu, you will invoke dialogs that are integrated with ProjectWise.  The same is true for right-click 
OPEN, SAVE AS…, and CLOSE commands executed from the InRoads Explorer. 

 

This means that any InRoads command that needs to open or save an InRoads data file will give you 
the opportunity to go into ProjectWise first.  If you cancel the ProjectWise dialog, the regular 
Windows dialog will open allowing you to navigate in the Windows file system.  If you cancel the 
Windows dialog, the command is canceled.  The sections below will show examples of both the 
ProjectWise and the Windows dialogs.  More information can be found about ProjectWise 
integration with InRoads in this PDF. 

Open… 

With InRoads V8i, it is easy to load InRoads data files of all types (*.rwk, *.dtm, *.alg, *.itl, *.ird, 
*.sdb, *.fwd, and *.xin) stored in the Windows file system using a simple drag and drop method.  
You can make a selection set of files in a Windows Explorer window, and then drag the files over 
the top of the InRoads Explorer. 

 
Tip! The drag and drop method can be used to load InRoads data files from the 
Windows file system, even while the active MicroStation design file is stored in a 
ProjectWise datasource. 

 

A Windows selection set is great to use if you have not saved a Project file (.rwk).  Consider this 
as an option to using FILE > OPEN… and changing the file types and navigating into your 

project folders for each file type. 

When the active MicroStation design file is stored in a ProjectWise datasource, the InRoads 
FILE > OPEN… command will cause a dialog that is integrated with ProjectWise to appear.  The 
integrated “Open” dialog allows you to locate and open existing InRoads data files that are 
stored in a ProjectWise datasource.  You may select and add multiple InRoads data files to the 
lower list and mark any of those files as read-only.  A quick search can be performed or a saved 
global or personal search can be executed by clicking the Search icon.  Search results are 
displayed in the upper document list. 

These commands invoke 
ProjectWise dialogs 

file:///C:/Program%20Files%20(x86)/Bentley/InRoads%20Group%20V8.11/ProjectWise%20and%20Plotting%20Integration.pdf
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Note: Files not marked read-only are checked out from ProjectWise and placed in the 
local working directory.  Files checked as read-only are copied to the local working 
directory, opened, and loaded, but are not checked out from ProjectWise.  The read-
only designation is retained when reloading InRoads data files using the File history. 

 

 
Note: Geometry project files (.alg) opened by InRoads will not show as checked out of 
ProjectWise.  The read-only check mark on geometry projects in the “Open” dialog is 
not applied.  InRoads controls the Read-Only and Read-Write access to individual 
alignments using “Access Control Details”. 

 

If you cancel the ProjectWise dialog, the Windows “Open” dialog appears and you can load 
InRoads data files, one at a time, from the Windows file system.  The Windows “Open” dialog 
stays open even after the InRoads data files have completed loading.  You must [Cancel] the 
Windows “Open” dialog to dismiss it. 

InRoads data files in ProjectWise 
selected to load into InRoads. 

Up One Level icon Search icon 

[OK] to load files from 
ProjectWise; [Cancel] to get 
to Windows file system.  
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When the active MicroStation design file is stored in a ProjectWise datasource, InRoads data 
files may be loaded from either a ProjectWise datasource or from the Windows file system and 
files from both locations can reside in the InRoads Explorer at the same time. 

 

Save 

The InRoads FILE > SAVE command is used to make incremental saves, but only to the active 
InRoads data (by type) as you are working.  A right-click SAVE in the Workspace Bar of the 
InRoads Explorer allows you to incrementally save any specific InRoads data file that you right-
click on.  The SAVE command does not cause any other dialog boxes to appear and records, in 

the message center, the full path to the saved file and that the save was completed. 

 

[Open] to load files from 
Windows; [Cancel] to 
cancel the command.  

Note that two surfaces are loaded from ProjectWise 
(pw:\\) and the other is loaded from Windows 
(\\wpdotfpsr818\Userseng\isd806\ODOT...). 
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Caution!  It takes two steps to save InRoads data and update the ProjectWise 
datasource.  The SAVE command saves to the local computer only.  The data in 
ProjectWise does not change until either [Check In] or [Update Server Copy] is chosen 
from the PROJECTWISE ORGANIZER…. 

Save As… 

The InRoads FILE > SAVE AS… command is typically used to create a file from data that is 
currently loaded or from data that was generated new in InRoads.  When the active 
MicroStation design file is stored in a ProjectWise datasource, the FILE > SAVE AS… command 

causes a ProjectWise “Save As” dialog to appear first.  A Windows “Save As” dialog will appear if 
the ProjectWise dialog is canceled.  The “Save As” dialog can be used to save all types of core 
InRoads data files by changing the Save as type: field.   

 
Note: A right-click Save As… on a specific type of InRoads data display name will 

open the “Save As” dialog already set to the correct type of file. 

 

 
Tip! The Save as type: field controls a filter that displays only the InRoads data 

for that type. 

 

To quickly have file names match names of InRoads data displayed in the InRoads Explorer, set 
the type first, then choose the display name from the Active: pull-down menu at the 

bottom of the dialog.  The file name: field will automatically be filled in and match the 
display name.  This behavior extends to both the ProjectWise and the Windows “Save As” 
dialogs. 

There is one additional step for saving a file in a ProjectWise datasource, which is to name the 
document.  It is preferable to have document names in ProjectWise exactly match file names.  
Select the File name: in the “Save As” dialog, Copy it to the clipboard, and Paste the 
name into the Document Name: field just above it. 

 
Tip! The Windows “Save As” dialog will populate the File name: field to match the 

display name only after selecting the display name from the Active: pull-down list.   
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The “Save As” dialog for both ProjectWise and Windows stays open even after the InRoads data 
files have finished saving.  The ProjectWise “Save As” dialog changes and displays a [Close] 
button after you click [Save] the first time.  You must click [Cancel] on the Windows “Save As” 
dialog to dismiss it. 

 

1. Set Save as type. 

2. Pick the data from the 
Active pull-down list. 

3. Copy the File name and 
Paste into Document Name. 

[Cancel] or [Close] when 
done. 

1. Set Save as type. 

2. Pick the data from the 
Active pull-down list. 

3. The File name is 
automatically generated. 

[Cancel] when 
done. 
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Close 

The Close command on the File menu is used to close all files of a particular type (geometry, 
surface, etc.).  The right-click Close in the Workspace Bar of the InRoads Explorer is used to 
close only the specific file that you right-clicked on.  It is recommended that you save changes 
prior to executing the Close command. 

 
Warning!  Save early – save often – save incrementally – save deliberately – save 
before printing, closing, or exiting.  It is not recommended to save during an exit or 
close operation, especially if the exit was not initiated by the operator. 

 

When the active MicroStation design file is stored in a ProjectWise datasource, after choosing 
Close, InRoads will ask you to confirm that you wish to close the file.  The ProjectWise “Local 
Document Organizer” dialog is suppressed in ODOT’s default configuration of ProjectWise, 
which could allow you to exit InRoads without checking in InRoads data files.  The InRoads data 
files you had loaded may not get updated in ProjectWise and may remain checked out and 
locked for other users. It is good practice to always save your data, then open File > 
ProjectWise Organizer… and use the “Local Document Organizer” to [Check In] or 
[Free] your InRoads data files.  If you have made changes to the InRoads data that you wish to 
update in ProjectWise, choose either [Check In - Leave Copy] or [Check In].  The option to [Free] 
will discard any locally saved changes and recycle the InRoads data file; [Free – Leave Copy] will 
leave the saved changes stored only locally on the C:\ drive and ProjectWise will not be updated. 

You should always use the File > ProjectWise Organizer… command to open the 

“Local Document Organizer” showing Checked Out Documents before you exit InRoads. 

Like the “Open” and “Save As” dialogs, the “Local Document Organizer” stays open after use, 
but there is no Close or Cancel button.  To complete the closing process, click the [X] at the 
upper right on the “Local Document Organizer” to dismiss the dialog. 

2. [Check In] saves changes 
to ProjectWise and checks in 
the document. 

1. Select and right-click on 
the files you just closed. 

3. [Free] discards changes 
and frees the document in 
ProjectWise. 
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ProjectWise Organizer… 

When the active MicroStation design file is stored in a ProjectWise datasource, the 
PROJECTWISE ORGANIZER… command will appear on the FILE menu in InRoads.  Because 

InRoads opens multiple data types, the ProjectWise “Check In” dialog does not appear when 
closing or exiting InRoads.  It is a good practice to open the “Local Document Organizer” soon 
after saving or closing InRoads data to allow you to check in or free ProjectWise documents.  
The “Local Document Organizer” dialog must be dismissed with the [X] in the upper right corner 
to complete the command that invoked the dialog. 

 

What follows is a good method for working with InRoads data: 

1. Save all loaded InRoads data files prior to exiting.  InRoads will detect unsaved changes 
and offer you a chance to save during another command to close or exit, but it is 
recommended that you deliberately save before exiting or closing. 

2. Close InRoads data files.  Closing a DTM or ITL does not update ProjectWise or check the 
file in.  Closing a geometry project (ALG) does check in all alignments. 

3. Open the “Local Document Organizer”, select specific files and choose a ProjectWise 
action.  If you are closing a DTM, then select just that DTM and click the ProjectWise 
action that you desire.  Do not select the active MicroStation DGN file.  Geometry 
project files (ALG) will not appear in the “Local Document Organizer”. 

4. Dismiss the “Local Document Organizer” using the [X] button in the upper right corner.  
The “Local Document Organizer” will stay open allowing you to select and manage other 
files in ProjectWise.  Even if you are exiting MicroStation and InRoads, leave the 
MicroStation DGN file checked out in the “Local Document Organizer”.  Other file types 
may be checked in at this time, but not if an application has them open. 

Note: All checked out 

documents appear in the list 

– XLSX, PDF, and DGN, too. 
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Exit 

Entirely exiting out of MicroStation and InRoads can be accomplished by choosing FILE > EXIT 
in MicroStation, or you may first choose FILE > EXIT on the InRoads Explorer and then choose 

FILE > EXIT in MicroStation.  Either way, you need to understand three things. 

 MicroStation is the platform product.  If you exit MicroStation, it must exit InRoads first. 

 If you only exit InRoads leaving MicroStation still running, and you want to relaunch the 
InRoads application, you’ll have to select APPLICATIONS > INROADS GROUP > 

ACTIVATE INROADS or select ODOT > INROADS LITE on the MicroStation menu. 

 You should open the “Local Document Organizer” dialog to manage the InRoads data 
files only.  If you attempt to check in or free the MicroStation DGN file while 
MicroStation is still open – you will get the following ProjectWise errors: 

 

If exiting, right-click on 
group (except DGN) and 
choose [Check In] or [Free]. 



ODOT InRoads® V8i User Guide 

Page | 32 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

 

 

 

[Cancel] and [OK] will leave you still running MicroStation, which provides its own 
“Check In” dialog when you exit the platform product. 

Project Defaults… 
FILE > PROJECT DEFAULTS… can be used for setting the initial directory locations for opening 
and saving files.  The “Set Project Defaults” dialog box allows you to choose or create 
configurations that are stored in your registry.  Configurations you create are specific to you, 
logged onto one particular computer.  That means if you create a configuration called myname 
on one computer, you will not see that configuration name if you log onto another computer 
and launch InRoads. 

A standard configuration named ODOT has been created and InRoads has been set to launch 
using the defaults that are set in the configuration named ODOT.  A batch file (run every time 
you logon) refreshes the ODOT configuration that is stored in your registry.  If you change the 
ODOT configuration, it will be refreshed with your next log on.  The configuration named ODOT 
does the following: 

Loads ODOT’s civil.xin from F:\ODOT_DATA\USERCFG\InRoads 
Loads V8i_ORStructures.dat from the workspace. 
Loads i_hydro.idf from the same directory as your open MicroStation design file, if 
i_hydro.idf is present. 

The Default Directory Paths are set so that when you load or save most file types, the 
default location is the same directory as your open MicroStation design file. 

You may want to use the FILE > PROJECT DEFAULTS… menu option to load or create another 
configuration. The new configuration will then continue to be loaded in future InRoads sessions 
until you log off and log back on, thus running the batch file, and resetting the defaults back to 
ODOT.  

If you have made a project specific copy of the standard preference file (keynu.xin), one way to 
load it (besides just dragging it in from Windows Explorer), is to create a Project Configuration. 
This is accomplished using the InRoads FILE > PROJECT DEFAULTS… menu option. 
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In the “Set Project Defaults” dialog (shown above) click the [New…] button, and in the “New 
Configuration” dialog, type in a configuration name and click [OK]. This will clear the existing 
fields.  Now simply click in a blank field (for example, next to Preferences (*.xin): and click the 
[Browse…] button.  If the active MicroStation DGN file is stored in a ProjectWise datasource, the 
[Browse…] button causes the ProjectWise “Select Folder” dialog to open. 

“ODOT” configuration 
loaded initially to set 
preferences and paths. 

Use [New…] to create a 
project-specific 
configuration. 
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You can bring up the familiar Windows “Open” dialog by canceling the Projectwise “Select 
Folder” dialog and can select your custom XIN file name and location from the Windows file 
system. When you have used the above method to fill in the appropriate fields you can click 
[Close] and answer [Yes] to the prompt to save changes. In future sessions you can use the FILE 

> PROJECT DEFAULTS… menu option to switch between the standard and your custom 
configurations by selecting a different Configuration Name and then clicking the [Close] button. 

Directory paths within a ProjectWise datasource are only available when the active MicroStation 
DGN file is stored in ProjectWise.  The ODOT configuration for default paths is designed to open 
InRoads data files that are stored in the same folder as the MicroStation DGN file.  This is true 
for data files stored in either the Windows file system or ProjectWise.  The path in the Report 

Directory field, however, when working in ProjectWise, is not used and when saving XML 
reports, the user is consistently placed at the top of the Documents folder in the ProjectWise 
data source. 

The Preferred Preference Name defines which preference will be loaded by default the first time 
you activate a command with a [Preferences…] button.  The Preferred Preference is initially set 
to the preference named ODOT.  This allows us to use ODOT as a system wide default 
preference name.  Should you develop project-specific preferences, a project-specific preferred 
preference name could be stored in a project-specific configuration of the project defaults. 

 

 
Tip: Drafters may prefer to set the Preferred Preference Name to ODOT-Plans, which 
will cause the preferences for annotating contract plans to be loaded by default when 
using the View Geometry commands. 

[Cancel] to open the Windows 
“Open” dialog for paths in the 
Windows file system. 
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Project Defaults Known Issues 

Button names should say what they do and do what they say.  The top two buttons in the 
“Set Project Defaults” dialog box have confusing naming.  Here is a translation: 

[Apply] = Save to registry – that’s all this does.  [Apply] does not affect what is currently 
loaded in InRoads. 

[Close] = Load what is currently entered in the dialog, offer to save changes to registry if 
they’ve not been saved, and dismiss the dialog box.  This is the button to push if you 
would like to load a configuration.  

 

 
Tip: If you open the Project Defaults, merely to glance at what is there, and you do not 
wish to load anything different – the only way to exit the dialog without doing 
anything is to use the [X] button at the upper right. 

Project Options… 

FILE > PROJECT OPTIONS… opens a dialog where you define project specific system operation 
parameters, the dialog is displayed below. 
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The FACTORS tab allows you to modify the scale at which text, cells, and linestyles are drawn 
when using InRoads display and annotation commands.  If using InRoads for drafting (displaying 
features, stationing, etc.) for plan sheets, you would want to set all the factors to one.  

 

You don’t have to open up the whole FILE > PROJECT OPTIONS… dialog to get at the scale 
factors either.  Use TOOLS > GLOBAL SCALE FACTORS to accomplish the same thing in a nice, 

compact dialog.  It provides a simple floating dialog allowing you to monitor and/or modify the 
active InRoads scale factors.  

 

The Default Access Modes section on the GEOMETRY tab works in conjunction with Access 
Control to establish your initial access mode when loading an .alg file.  The default access modes 
are applied only after determining that an alignment is not locked with write access by another 
user. 

It is recommended to set the “Default Access Modes” to Read-Only for the Horizontal 
Alignments.  This setting is saved in the ODOT preference which is loaded by default when 
InRoads is launched.  You may, of course, save a personal preference, set differently, in a 
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custom civil.xin file.  Alignments may be viewed, annotated, modeled, and reported on with an 
access mode of Read-Only, therefore, it is recommended that only designers set a default access 
mode of Read-Write. 

  



ODOT InRoads® V8i User Guide 

Page | 38 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

 

 

Translators 

LANDXML TRANSLATOR 

The LandXML Translator allows you to import data files from and/or export to LandXML. 

TRANSLATE LEICA DBX 1200… 

ODOT surveyors may not normally need to use this function.  Surveyors will typically be 
using LGO to InRoads, a utility from Leica, to translate raw data in DBX format into an 
InRoads fieldbook (.fwd) and to translate the Leica codes into InRoads Survey codes. 

EXPORT LEICA DBX 1200… 

FILE > EXPORT LEICA DBX 1200… exports geometry and surface data into the Leica DBX 
1200 format.  This tool will be used to create DBX files from alignments.  The DBX formatted 
files can then be loaded onto a data card and inserted into a Leica System 1200 GPS/TPS for 
field stakeout. 

Export Leica DBX… Known Issue 

The “Export Leica DBX 1200” dialog does not allow use of UNC syntax to describe a 
network location to store the DBX files.  If the Target Directory field shows a 
UNC location - \\servername\foldername, you will not get an error, but instead of the 
expected DBX files, only one .xml file will be created.  Use the ellipsis button, […] and 
navigate to a mapped drive location. 

 

 

  

file://///servername/foldername
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Surface 

Feature based DTMs 

DTMs are made up of features.  A feature is a named set of points in a Digital Terrain Model 
(DTM). A feature can be one of five types, corresponding to the type of DTM points contained: 
random, breakline, exterior boundary, interior boundary, or contour. Features are essentially 
just groups of DTM points – each group is given a name and assigned a style (styles control 
everything about how surface features get displayed). The ability to identify different features 
by name, to select and edit them using filters, and to independently control their display 
characteristics, are benefits of organizing a DTM into features. 

Design features are named so as to make them easy to identify and manipulate.  

Design features are assigned a style that allows them to know what they represent, and where 
and how they can be displayed.  

Features do not have to represent terrain model data.  

 

 
Note: Non-triangulated features can be stored in a surface along with terrain defining 
features, and they can be displayed and annotated from that surface and used for 
control in corridors. 

View Surface>Features… 
ODOT has adopted the use of annotation scale, which affects how point features are displayed 
from surfaces.  Surveyors and designers will notice that workflows for displaying topo or 
basemap graphics have changed in order to apply annotation scale. 

Point features use named symbologies for plan view graphics that will place cells that are sized 
for use with annotation scale.  That means the cells are scaled down 1200 times and will appear 
as tiny points when displayed using the SURFACE > UPDATE 3-D/PLAN SURFACE DISPLAY or 

SURFACE > VIEW SURFACE > FEATURES… commands.  After displaying the graphics in a model 
with 1”=100’ drawing scale, make a selection set of InRoads annotations, then click on the “Add 
Annotation Scale” button. 

 

 

 

Adding Annotation Scale will multiply the size of the cells by the drawing’s annotation scale and 
make the cells visible.  The cells will also now respond to the rules of annotation scale; when the 
drawing scale is changed or the drawing is referenced into a drawing of a different scale, the 
annotations will change size to adjust to the new scale. 

Add Annotation 

Scale 
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Edit Surface 

Commands for modifying and manipulating surfaces include more than just Delete Triangle.  
With increased use of intelligent DTMs, it becomes easier to document changes to a design or 
survey by editing the features.  SURFACE > EDIT SURFACE… contains commands to edit or 

delete feature points.  If you have used Pencil mode when viewing graphics, edits to the 
features are automatically updated in the graphics in the design file.  Once you’ve modified a 
portion of a feature, don’t forget to retriangulate the surface. 

 

 
Tip: Surface > Design Surface > Generate Longitudinal Feature… can be very handy 
for creating offsets to features by checking the box “Generate Graphics Only”.  This is 
especially useful for striping!  You can create an offset taper and apply a different 
feature style at the same time. 

 

Feature Selection Filter 

The Feature Selection Filter affects only dialogs where you can select filters.  These dialogs have 
a [Filters…] button and display the list of features from the active surface.  Surface feature filters 
and the Feature Filter lock work together to affect the operation of any command whose dialog 
box contains a surface features list. Two examples of commands with features lists are: SURFACE 
> VIEW SURFACE > FEATURES… and EVALUATION > CROSS SECTION > CROSS 

SECTIONS….  The following filters are provided in ODOT’s standard civil.xin: 

All Lines 
All Points 
BASEMAP TOPO 
BreaklineDNT 
Prop Lines 
Prop Points 
Extg Lines 
Extg Pipes 
Extg Points 
Label Features 
RandomDNT 
TRIANGULATED FEATURES 

To apply the filter, turn the Feature Filter Lock on.  All other features are filtered out of the open 
dialog.  It is features from the ACTIVE surface that are shown in the “Feature Selection Filter” 
dialog.  So if the Current Results list shows a different set of features, simply check which surface 
is active on the SURFACE tab of InRoads Explorer.  The filter will act on the chosen surface in the 
current dialog, even if it is not the active surface. 

Feature Filter Lock 

When the lock is on, only surface features that meet the criteria of the active Feature Selection 
Filter are displayed in the surface features list on any dialog box. Limiting the surface features in 
this way allows those commands to operate only on the surface features that meet the filter 
criteria. When the lock is off, surface feature filters have no effect, and surface features lists on 
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dialog boxes show every feature in the active Digital Terrain Model (DTM). Feature Filter Lock is 
located at TOOLS > LOCKS > FEATURE FILTER. 

DTM Identifiers 

One aspect of DTMs is the unique identifier that InRoads assigns when a surface is created. You 
will never see this identifier as it is only used internally by InRoads, but it may affect the way you 
work. If you make a copy of a .dtm file, either from within Windows Explorer or by using the 
InRoads FILE > SAVE AS… menu option, that copy will retain the identifier that was assigned 
to the original surface. Even if you then modify the copied surface (re-name, edit features, etc.) 
InRoads will tell you that it is the same as the original surface and will not allow you to load both 
at the same time. If you need to make a copy of a surface intending to modify it, then you want 
to use the InRoads SURFACE > COPY SURFACE… menu option so that the copy will be assigned a 
new identifier. 

Surface Properties 

You can lock the triangulation of a surface, which will prevent the surface from being re-
triangulated and will prevent any reminders, in the form of a pop up, warning you that triangles 
may truly or falsely be out-of-date.  If you lock the triangulation, the onus is on you to 
remember that you have imported a feature that you now wish to triangulate into the DTM, or 
that you have deleted DTM points or triangles and you may need to re-triangulate to correct the 
DTM.  Locking triangulation can be handy for those who prefer to delete triangles to clean up 
around the edge, instead of placing an exterior boundary, but do remember that all it takes is to 
re-triangulate without that exterior boundary and you get your mess back again!  The “Lock 
Triangulation” check box is on the MAIN tab. 

Surface Preferences and Symbologies 

In addition to storing intelligent features, a surface contains added intelligence that determines 
how it can be displayed.  Each surface can be saved with an assigned preference and up to 18 
assigned named symbologies.   
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The PREFERENCE field with a drop down list is on the MAIN tab of the “Surface Properties” 

dialog. This drop down list allows you to assign a preference to your surface that will determine 
how triangles, contours, etc. will be displayed in plan view. The drop down list acts differently 
than a [PREFERENCES…] button would in other dialogs. The drop down here lists all named 
preferences from the .XIN file as opposed to a [PREFERENCES…] button that only lists sets 
appropriate for the current command. 

In the ODOT standard civil.xin file there are six preference sets defined for surfaces: Default, 
DTM_Existing, DTM_Subgrade, DTM_Rock, DTM_Finish, and ODOT. The differences 
between these preferences are mainly just the color with which triangles, etc. are displayed.  
These preferences are only applied when Style Lock is on.  When Style Lock is on and the 
preference is not initialized for plan view – you’ll still get View Surface graphics drawn with the 
preferred preference – ODOT. 

If you don’t operate with Style Lock on, you’ll get the “View Surface” dialog box popping up, 
displaying – guess what? – that’s right, the preferred preference symbology, nice and green– 
even if you do set a named preference in the Surface Properties.  

The drop down list for Surface Preference contains the names of all preference sets defined 
within ODOT’s civil.xin file although most of these preferences are not initialized for use with 
surface display. The only valid preferences for surfaces are the ones that begin with DTM_, and 
as luck would have it DTM_ is alphabetically right after Default so it’s fairly easy to get where 
you want to be in the drop down.  These preferences can be set after the surface is created, just 
don’t forget to save the surface.  A save will record the change to the properties in the .dtm file 
saved to disk. 

Now let us add to the confusion by looking at the ADVANCED tab of the “Surface Properties” 
dialog. 

Preference 
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The ADVANCED tab is used to assign symbology to a surface to determine how that surface line 
will be displayed in Cross Sections and Profiles. As you can see, the Profiles portion of the dialog 
also allows you to pre-define offsets distances and symbology for multi-line profiles.  The drop 
downs provide a list of all named symbology sets found in ODOT’s standard civil.xin file. 

 

 
Note: Remember that named symbologies are groupings of symbology settings - 
level, color, weight, etc. 

This can be somewhat confusing since these drop downs show a different list than the drop 
down on the MAIN tab. The difference is that the MAIN tab drop down is used to assign a 
preference, these drop downs are used to assign named symbology. In the ODOT standard 
civil.xin file we have several named symbologies for each surface type. The difference being the 
number added to the end of the symbology name, (IE: DTM_Subgrade1) which represents the 
color with which the surface line will be displayed in cross sections or profiles.   Symbology 
names without numbers simply indicate that the color matches that which is assigned to the 
preference of the same name for correlation between plan view and cross section or profile.  
Several examples are listed below, showing symbology for cross section lines. 

DTM_Subgrade1 = Level P_RDWY_XSECT_Subgrade, co=1 (blue), LC=3 (short dash), wt=2 
DTM_Finish4 = Level P_RDWY_XSECT_FinGrade, co=4 (yellow), LC=0 (solid), wt=1 
DTM_Existing2 = Level E_RDWY_XSECT_FinGrade, co=2 (green), LC=0 (solid), wt=3 
DTM_BaseRock5 = Level E_RDWY_XSECT_General, co=5 (magenta), LC=1 (dot), wt=2 
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Surface Known Issues 

Surface Preferences 

New surfaces are typically created with a Default Preference set to Default on the “Create 
Surface” dialog.  It may not be necessary to change the Preference on the MAIN tab of the 
“Surface Properties” dialog, as this preference is used only when Style Lock is on.  If it is 
normal for you to operate with the Style Lock off, then you can pretty much ignore this 
preference. 

Surface Display Name Length Limit 

Surface display names should be shorter than 32 characters.  When the name of the surface 
exceeds 32 characters, end-area volumes from components displayed in cross section with 
material styles may not be included in the material totals reported using volumes.xsl.  
Because corridor names may be used to create surface names, it is recommended to also 
limit corridor names to less than about 28 characters.  This shorter limit is to allow for an 
alternate surface suffix such as –SG. 

Surface Feature Description Field Length Limit 

The description of a feature should be limited to 62 characters or less.  The description field 
of a feature will allow 63 characters to be entered; however, if 63 characters are used, the 
display of the northing and the description when using “Annotate Features” will be 
incorrect.  The northing will be replaced with the style name and the description will be 
annotated with the style name at the end.  A tip for data entry into the feature description 
field is to type until no more characters may be entered, then backspace one space to 
remove the 63rd character. 

Geometry 

Superelevation 

The maximum superelevation rate and the design speed for the curves in a corridor are stored in 
the horizontal alignment.  The maximum superelevation rate for each curve in your alignment 
can be entered using GEOMETRY > SUPERELEVATION > RATE CALCULATOR…  The 
“Superelevation Rate Calculator” dialog box is a misnomer.  It’s not really a calculator.  It’s just a 
Reviewer.  It has a handy [Edit…] button, which can be used to either enter your own values 
(recommended), or calculate an ‘e’ value using several different methods or look up tables.  The 
values displayed in this dialog are read from the horizontal alignment.  
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The “AASHTO Wizard” dialog, which you can access from the Create Superelevation Wizard in 
the Roadway Designer, also displays the very same values and offers you a method for 
reviewing, editing, and calculating the maximum ‘e’ value via another [Rate Calculator….] 
button. 

 

If your workflow includes applying the appropriate length spiral for your curves when you create 
the horizontal alignment, it is recommended that when you look up the spiral lengths in the 
ODOT Highway Design Manual, you note the design speed and maximum ‘e’ value given for your 
degree of curve.  Select the curve in the “Calculator” dialog and click the [Edit…] button to open 
the Superelevation Rate Calculator Editor.  Enter the Design Speed and skip all the way down to 
the Computed Rate: field and enter the maximum ‘e’ value from the ODOT Highway Design 
Manual.  
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It doesn’t matter which method is listed in the Method: field – just leave it set to AASHTO 
Method 1.  The method is used only if you use this dialog box as a calculator. 

Saving the design speed and the maximum superelevation rate for the curve to the horizontal 
alignment requires that you click [OK] on the “Editor” dialog, and also click [Apply] on the 
“Calculator” dialog. 

 

 
Note: Make sure you apply changes before you close the “Calculator” dialog, 
otherwise your entries will be lost. 

 

Once the design speed and superelevation for the curve are entered and stored in the horizontal 
alignment, they will appear in the report generated by GEOMETRY > REVIEW HORIZONTAL…  
They will also appear when you annotate your horizontal alignments. 
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Geometry Styles and Symbologies 

Geometry style definitions have been incorporated into the civil.xin file.  The definitions 
determine symbology settings for display of geometry elements (level, color, weight, linestyle), 
and also determine how geometry elements will be annotated.  The ODOT civil.xin file contains 
styles which have geometry definitions for various types of roadway alignments as well as some 
other elements commonly used to define alignments (IE: curb, stream, pipe, etc.). Geometry 
styles are assigned when creating an alignment by selecting from the drop down labeled “Style:” 
in the “New” dialog on the Geometry tab. (see below where the default style ODOT has been 
selected). They can also be assigned via a similar drop down found in the “Active Geometry” 
dialog. 

 

Geometry points have styles assigned specifically to them for horizontal annotation.  The styles 
are named P.C., P.I., P.T., etc. 
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When the ODOT preference is loaded, the Styles tab of the 

“View Horizontal Annotation” dialog is filled out as shown above 
and the point styles that are shown in the dialog are used. The 
corresponding named symbologies for the geometry point styles 
place the on-board symbol, “cross”, in a cyan blue color, at the 
cardinal points along the alignment on level P_RDWY_ALIGN_Main. 
The symbology for elements is taken from the active style that is set 
on the Main tab, which is also named ODOT. 

 

 
Note:  The preference set named ODOT uses the geometry point symbology for 
quick display of alignment graphics. 

 

The ODOT preference has been configured so that when alignment points are displayed during 
a right-click VIEW command or when using GEOMETRY > VIEW GEOMETRY > ACTIVE 

HORIZONTAL and ACTIVE VERTICAL menu options, you will get on-board symbols for cardinal 
points that display and update quickly during design activities.  You will get these quick symbols 
regardless of the style that is assigned to the alignment. 

The ODOT-Plans preference uses geometry symbologies for cardinal points that match the 
ODOT standards for contract plans when using GEOMETRY > VIEW GEOMETRY > HORIZONTAL 

ANNOTATION and VERTICAL ANNOTATION menu options, again, regardless of the assigned style.  
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Both preferences, ODOT and ODOT-Plans, set and use active styles on the Main tab.  There 
is a huge difference between the style that each preference uses! 

ODOT-Plans uses a style named CL_Main.  Text and points placed with the CL_Main style and 
symbology are configured for use with Annotation Scale.  InRoads V8i will not actually apply 
Annotation Scale, so our annotation workflow involves placing cells and text 1200 times smaller 
than normal, then using the Add Annotation Scale button [+A] in a 1”=100’ drawing scale model 
to size it up and make it respond to the rules of annotation scale. 

 

 
Note: Remember that a preference is a saved set of parameters defining how a 
command operates. 

 

Shown below is how the Styles tab of the “View Horizontal Annotation” dialog appears when 
the ODOT-Plans preference is loaded.   

 

The ODOT-Plans preference causes “Display Alignment Points Similar to Cogo Points” to be 
checked.  There are no Cogo Point styles defined, so the alignment’s assigned style ends up 
overriding the point styles shown for each point.  When using the ODOT-Plans preference, 
cardinal points will be placed as cells, because that is how they are defined in the alignment 
styles. 
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Note:  The preference set named ODOT-Plans uses CL_Main symbology, which 
places text and cells scaled down 1200 times for annotation scale.  They will not 
display correctly until annotation scale is added. 

 

All of the CL_* styles use CL_* symbologies that are configured for use with 1”=100’ annotation 
scale. 

Right of Way and Survey geometry styles and symbologies have also been configured for use 
with annotation scale.  The following symbologies have been configured for use with annotation 
scale in models with a drawing scale of 1”=50’. 

RW_Extg 
RW_CL_Sec 
RW_CL_Prim 
Surv_CL_RR 
Surv_Main 
Surv_Minor 
Surv_Ramp 

 

 
Note:  The geometry styles for RW and Survey alignments will place text and cells 
scaled down 600 times for annotation scale.  They will not display correctly until 
annotation scale is added. 

Geometry Related Preferences 
We’ve already touched on two main preferences that are used for display of plan view 
geometry, ODOT and ODOT-Plans.  The most commonly used geometry related preference 
sets are those used for display of stationing.  The list below shows all of the preferences 
available for viewing stationing.  

CL_Bikeway_Inch100 
CL_Bikeway_Inch200 
CL_Bikeway_Inch50 
CL_Detour_Inch100 
CL_Detour_Inch200 
CL_Detour_Inch50 
CL_Ditch_Inch100 
CL_Ditch_Inch200 
CL_Ditch_Inch50 
CL_Existing_Inch100 
CL_Existing_Inch200

CL_Existing_Inch50 
CL_Main_Inch100 
CL_Main_Inch200 
CL_Main_Inch50 
CL_Minor_Inch100 
CL_Minor_Inch200 
CL_Minor_Inch50 
CL_Ramp_Inch100 
CL_Ramp_Inch200 
CL_Ramp_Inch50 
ODOT 

ODOT-Plans 
ODOT-PlanSheetInch200 
ODOT-PlanSheetInch50 
RW_Prim 
RW_PrimInch100 
RW_Sec 
Surv_Main 
Surv_Minor 
Surv_Ramp 
Surv_RR 
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Preferences that end with Inch100 and the ODOT-Plans preference are configured to be used 
in models with a drawing scale of 1”=100’.  When Annotation Scale is added, the drawing scale 
of 1”=100’ will scale selected text and cells up 1200 times to the correct size for use in a 1”=100’ 
plan sheet.  Inch200 preferences are for use in models with drawing scale of 1”=200’, and 
Inch50 preferences are for use with 1”=50’ drawing scale models.   

There are also preferences used in the View Geometry commands named RW_* and Surv_*.  
These preferences are configured for annotation in a model with a drawing scale of 1”=50’.  This 
means that the leaders and ticks will be the correct length for a scale of 1”=50’.  If the alignment 
will be referenced into a drawing with a different scale, the annotation text and cells will 
automatically adjust, but the leaders and ticks will remain the same. 

 
Tip: If you are a designer, making changes to geometry, use the ODOT preference set 
for quick geometry annotation.  If you are annotating for contract plans, use the 
ODOT-Plans preference set and the Add Annotation Scale tool in MicroStation.  

 

Geometry>Horizontal Annotation 

The ODOT and ODOT-Plans preferences are configured to draw alignment elements and 
points for the selected alignment.  In addition, the tangent elements will be annotated with the 
bearing.   The ODOT preference is set up for quick annotation and does not meet the ODOT 
standards for contract plans.  It is intentionally configured to display different fonts and colors of 
symbols so that a designer has clear visual cues that the annotation is not standard.  The 
ODOT-Plans preference set for horizontal annotation has been configured for use with an 
annotation scale of 1”=100’.  When annotating an alignment for use in contract plans, a designer 
need only horizontally annotate with the ODOT-Plans preference set loaded, and add 
annotation scale.  The bearing text will adjust its size if the drawing scale is changed. 

 

 

 

 

 

  

Bearing using ODOT 

preference. 

Bearing using 

ODOT-Plans 

preference. 
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The RW_* and Surv_* preferences are configured to draw and annotate elements only.  They 
will not display points.  Spiral and tangent elements will be annotated with spiral and bearing 
information.  Adding annotation scale is necessary for the annotation to be displayed correctly.  
Again, RW_* and Surv_* preferences are designed to be annotated in 1”=50’ drawing scale 
models. 

Geometry>Vertical Annotation 

The ODOT and ODOT-Plans preferences are configured to draw vertical alignment elements 
and points in profile sets for the selected vertical alignment.  Once again, the ODOT preference 
set is configured for quick annotation and does not use the ODOT standards for contract plans.  
The symbologies that are used will place on-board symbols that are cyan blue-colored, “plus” 
and “cross”.  A vertical mono-spaced font is used for text so as to be obvious in not being 
standard. 

The ODOT-Plans preference for vertical annotation differs from the horizontal annotation in 
that it uses text and cells sized to be used without annotation scale.  ODOT-Plans will place 
vertical geometry annotation that immediately meets the ODOT standards for 1”=100‘ contract 
plans. 

 

Vertical annotation 

using ODOT 

preference: Cyan blue 

symbols, ODOT Vertical 

Mono font. 
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Geometry>Stationing 

Using InRoads V8i’s View Stationing command, we are better able to match ODOT point 
annotation drafting standards for contract plans.  It is an ODOT standard to show cardinal point 
stationing with the station first, followed by the point abbreviation.  For all preferences, the 
option to “Swap Point Abbreviation and Station” has been checked on for the CARDINAL POINTS 

leaf of the GEOMETRY > VIEW GEOMETRY > STATIONING… command.  Then, the ODOT 
preference set inserts the spaces ODOT requires using the Point Abbreviations section of the 
ABBREVIATIONS tab of the “Project Options” dialog box.  (The “Project Options” dialog is located 
in FILE > PROJECT OPTIONS….)   For example, what was previously stationed as P.S.C. 
117+12.28 is now stationed 117+12.28 P.S.C.  PIs will not respond to the “Swap” option and 
when PIs are placed for RW or Survey annotation, they must be manually edited. 

Only one preference is set up for immediate viewing of station text – ODOT.  All other 
preferences use text sizes that are scaled down and will require the use of the Add  
Annotation Scale tool.  ODOT-Plans and *_Inch100 preferences are to be used to annotate in 
1”=100’ drawing scale models, RW_* and Surv_* preferences use 1”=50’ drawing scale. 

 

The ODOT-Plans preference set and *_Inch100 preference sets for stationing display have 
been configured for use with an annotation scale of 1”=100’.  As with the horizontal annotation, 

Vertical annotation 

using ODOT-Plans 

preference: ODOT 

standards for contract 

plans. 

Stationing using ODOT 

preference: ODOT 

Vertical Mono font. 
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when stationing text and cells are placed in the file, they are scaled down 1200 times.  Adding 
annotation scale to the stationing text and cardinal point cells does not affect regular elements.  
You will see the text and cells scale up 1200 times in your 1”=100’ drawing scale model, and the 
size of the annotation text and annotation cells will automatically be adjusted when they are 
referenced into a model with a different drawing scale. 

If an alignment is to be stationed for future referencing into 1”=200’ plan sheets, the stationing 
should be annotated in a model with drawing scale of 1”=200’.  The different offsets and lengths 
of leader lines and ticks will be accounted for by loading any stationing preference that ends 
with Inch200.  Likewise, if an alignment needs to be stationed for future referencing into 1”=50’ 
plan sheets, the stationing should be annotated in a model with drawing scale of 1”=50’.  To 
achieve 1”=50’ offsets and lengths of leader lines and ticks, load any stationing preference with 
a name ending with Inch50. 

For example, if you will be referencing an annotated alignment into a 1”=50’ scale drawing, use 
InRoads V8i to annotate the geometry and work in a model with drawing scale set to 1”=50’.   
When viewing the stationing, load the preference named ODOT-PlanSheetInch50 to place 

adjusted tick and leader lengths.  Add Annotation Scale (click  while in the 1”=50’ drawing 
scale) and then reference the annotated alignment into the 1”=50’ drawing.  The annotations 
will respond to changes in drawing scales by changing size, however offsets, leader lines, and 
ticks are not annotations and will remain fixed.   

When it is necessary to add the alignment name to the annotation, this is most easily done in 
InRoads V8i without using station equations.  The “Stationing” dialog allows a prefix for Major 
Stations on the Regular Station leaf, which is where the alignment name is entered.  There is 
also a Prefix for Cardinal Stations.  If the alignment has a station equation solely to add the 
alignment name, you should check the box to “Drop Station Equation Name” on the General 
leaf.  If you would like the alignment to be drawn 2D, check the “Planarize” box. 
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Don’t forget to enter the same prefix on the Cardinal Stations leaf. 

Geometry>Curve Set Annotation 

The ODOT preference set for Curve Set Annotation is configured for quick display and is not set 
up for annotation scale.   

Curve set data is required to be displayed in specific formats for contract plans.  Using InRoads 
V8i, you are able to annotate alignment data using two preferences designed for “plans” – 
ODOT-Plans and ODOT-Plans_unequal_spirals. 

The ODOT-Plans preference should be used to annotate curve set data for alignments that 
have equal spirals.  ODOT-Plans is configured to place only the curve set data according to 
ODOT drafting standards for contract plans with text that is sized for annotation scale of 
1”=100’.  A couple of edits are necessary, which include moving the direction of the curve (L/R) 
from the Total Delta line up to the Degree of Curve line and entering the alignment name.  A 
suffix has been added to the Degree of Curve to remind you to make that edit. 
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The images above show the ODOT-Plans preference configuration and the result after adding 
annotation scale. 

 
Note:  Curve set annotation for plans will have to be edited slightly to match 
what is required by the Contract Plans Development Guide. 

The ODOT-Plans_unequal_spirals preference has been created to assist with annotating 
curve sets that have unequal spirals and more closely match ODOT drafting standards for 
contract plans.  ODOT-Plans_unequal_spirals separately annotates each element of a curve 
set, and displays only the delta angle of the curved element and spiral lengths. 

Curve set annotation:  

ODOT-Plans 

preference. 
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If you have an alignment with unequal spirals, you will annotate curve sets first with the ODOT-

Plans preference, remove the user data or convert pencil to ink, then annotate the curve sets 
with the ODOT-Plans_unequal_spirals preference, and combine the information into the 
curve set data. 

    

The annotations on the unequal spirals will need to have the name of the alignment entered 
and the text moved to a reasonable location. 

ODOT-Plans_unequal_spirals  

produces central curve element 

annotation that will be deleted. 

ODOT-Plans_unequal_spirals  

produces spiral curve element 

annotation that will be used. 

becomes… 
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The RW_* and Surv_* preference sets have been configured for use in 1”=50’ drawings and to 
annotate similarly to the way they functioned in previous versions of InRoads.  Text has been 

scaled down 600 times and requires using the Add Annotation Scale tool.     

 

  

Curve set annotation:  

ODOT preference. 
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Geometry known Issues 

Horizontal Annotation - Stacked vs Along 

When defining styles for Geometry features, there are two orientations for displaying text, 
ALONG or STACKED. (SEE DIALOG BELOW.) 

 

When ALONG is selected the annotation will be placed as individual characters along any 

curved geometry element and placed as a single line of text along a straight element. When 
STACKED is selected the annotation will be placed as a text node. STACKED would appear to 

be the desirable method, except that the annotation is stacked about the center of the 
element and it would need to be moved. The ALONG method does not cause orientation 

problems, but the individual characters are much harder to deal with.  This is noted for you 
to be aware that ALONG may result in annotation that is difficult to edit or move because 

sometimes the opposite occurs. 

Horizontal Annotation – Inside / Outside of Curve 

The choice of how to place the annotation is also defined on the geometry style.  In the 
image of the "Edit Style” dialog above, you may notice that Annotate is set to “Inside of 
Curve Only”.  Unfortunately, this setting does the opposite of what is indicated and places 
the curve set data on the outside of all curves.  A defect has been logged with Bentley and 
our workaround is to set it to the opposite of what is desired. 

View Stationing with Station Equations 

With a major station interval of 500’, the subsequent major station (and its tick) following a 
station equation will not be displayed.  A defect has been logged with Bentley and the 
workaround is to use manual methods to place the tick and the station text. 
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Drainage 
InRoads V8i includes a DRAINAGE menu item and a DRAINAGE tab on the InRoads Explorer window, 

even when you have not added in the Storm & Sanitary product.  You may load a drainage database 
(.sdb) into InRoads V8i and review/edit the structures as well as view the structures in plan view.  
Editing the structures in the database is limited to setting a Top Height on inlets and manholes and 
setting styles for display. 

Drainage Preferences 

Even if not actually running Storm & Sanitary, it is possible to view drainage networks and 
structures in plan view.  The ODOT preference set has been configured to display drainage 
objects that are typically displayed in contract plans and to use the symbology that is normally 
used for contract plans.  Pipe and culvert center lines will be drawn and cells will be placed to 
locate manholes and inlets.  The drainage preferences have not been configured to work with 
annotation scale, however.  The text and cells placed with the View Drainage tools will display 
the correct size for 1”=100’ contract plans only.  You should place your drainage annotations in a 
separate model to avoid adding annotation scale where it is not necessary.  The annotated 
drainage network will not respond to annotation scale when referenced into a model with a 
different drawing scale. 

Survey 

View Survey Data 

Planimetrics 

When viewing planimetrics from a fieldbook, temporary graphics use annotation cells found 
in Road.cel and EXTG.cel.  Because the annotation cells have been scaled down 1200 times 
for annotation scale, the temporary graphics for the points were not readily visible.  The 
ODOT preference set for Survey Options has been modified with a cell scale of 1200 to 
cause the cells to be easily viewed. 

 
Caution: Do not add annotation scale to cells displayed with a Cell Scale of 
1200.  If you do, the cells will be 1200 times too large!  Survey processes are to 
add annotation scale after displaying topo points from a DTM.  Annotation 
Scale should not be added to fieldbook planimetrics. 

Notice the gap in 

major stationing? 
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Evaluation 

Profile 

Profile Preferences 

The default (ODOT) preference for displaying profiles is adequate for design purposes. 
Most designers will likely profile the entire horizontal alignment in one big window. For 
drafting purposes, an attempt has been made to provide preference sets appropriate for 
displaying profiles for use on contract plan sheets. These preference sets are named based 
on the intended plotting scale (IE: Prof_1”=50’, Prof_1”=100’, and Prof_1”=200’). To make 
these profiles fit a plan sheet border, station and elevation limit values have been entered 
on the CONTROLS leaf of the “Create Profile” dialog, but are toggled off. The actual values 
won’t match your project stationing or elevations, but if you can modify them while 
maintaining the interval, the profile window will fit inside the border. When prompted to 
place profile you can snap to the lower left corner of the plan sheet border (heavy blue line, 
not light yellow line) to align grid with border. 

All preferences for displaying profile annotation are configured to place text and cells 
without annotation scale.  You should place your profiles and profile annotations in a 
separate model from plan view graphics to avoid adding annotation scale where it is not 
appropriate.  The annotated profile will not respond to annotation scale when referenced 
into a model with a different drawing scale. 

 
Caution: Do not add annotation scale to profile or cross section graphics.  The 
text and cells in profiles and cross sections are not configured for annotation 
scale. 

Cross Section 

Cross Section Preferences 

There are eleven different preferences to choose from when plotting cross sections.  The 
ODOT preference set displays stacked sections with 5 sections per column.  The ODOT 
preference set is best used during design when you are interested in viewing your cross 
sections in a design file, but don’t intend to print.  The designer ensures that the width is 
sufficient to show all design details by manually setting the left and right offsets to establish 
the range. 

The other ten sheet format preferences have been provided for plotting at 1”=10’, 1”=20’, 
and 1”=40’ scales on 11” x 17” paper. Depending upon the preference set name, the cross 
section sheets will be stacked vertically upward or horizontally rightward and will be sized 
and spaced to allow you to place a border cell using the General task grouping found on 
most ODOT discipline-specific workflows.  The *ForAnnotation preferences stack vertically 
and leave sufficient space for annotations. 

A border cell may be snapped to the sheet border shape drawn by InRoads.  If you wish to 
use contract plans border cells, you will need to work in a model whose annotation scale 
matches the scale of the preference name.   For fence printing without a border cell, you 
can place a fence from element using the InRoads border shape.  That will produce the 
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correct print scale when 11” x 17” paper is selected.  When using Print Organizer, the print 
style named _PDF_Xsections_11x17 creates print definitions with fences defined by the 
location of the InRoads border; it is not necessary to place a border cell.  Click on the 
[Preferences…] button near the bottom of the “Cross Sections” dialog to select another 
preference set. 

Inch10forAnnotation 
Inch20ForAnnotation 
Inch40ForAnnotation 
ODOT 
Xsec1”=10’_Up_3Col_40’Range 
Xsec1”=20’_Up_2Col_140’Range 
Xsec1”=40’_Rt_1Col_600’Range 
Xsec1”=40’_Rt_2Col_280’Range 
Xsec1”=40’_Rt_3Col_180’Range 
Xsec1”=40’_Rt_4Col_120’Range 
Xsec1”=40’_Up_4Col_120’Range 

An example of how this could work is: 

In the “Cross Sections” dialog, select the CREATE CROSS SECTION leaf, click the 
[Preferences…] button, select and load the Xsec1”=20’_Up_2Col_140’Range preference and 
click [Apply]. When prompted to identify location, place the cross sections.  Then select the 
11 x 17 border from the General>Sheet Borders task and snap to the lower left corner of the 
InRoads border shape. 

 

An 11” x 17” border is being placed 

atop cross sections drawn with 

Xsec1’’=20’_Up_2Col_140’Range 

preference in a model with drawing 

scale set to 1”=20’. 
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For those of you who prefer to produce cross sections on 11” x 17” paper, with a titleblock, 
there are preference sets for you as well.  The group of preference sets named 
Xsec1’’=40’_Rt_* were configured for use with the standard ODOT border, leaving space 
for a contract plans titleblock. 

Cross Section Report… 

In InRoads V8i, reports from cross sections are generated using EVALUATION > CROSS 
SECTION > CROSS SECTION REPORT…  See the Workflow section for instructions on how to 
create a grade report. 

Cross Section Known Issues 

Cross Section Sets Will Update Even If Model Is Not Active 

The “Cross Sections” dialog lists all of the Cross Section Sets that have been cut, in all of 
the models in the file.  And the Update CROSS SECTION leaf will act on a Cross Section 

Set that is not displayed in the active model. 

 
Caution: Be careful to not update cross section sets in other models – sets you can’t 
see!  Always use the target button to the right of the Cross Section Set list to select the 
cross section set you wish to update in the active model. 

 

Including Crossing Features and Components 

When you check the boxes on the INCLUDE leaf of the “Create Cross Section” dialog to 

include “Crossing Features” and “Components”, understand that all of the crossing 
features and all of the components from all of the selected surfaces will be displayed in 
the cross sections.  It is best to be selective about which features are displayed in cross 
sections, so that your reports contain only features for which you require grades. 

The UPDATE CROSS SECTION leaf on the EVALUATION > CROSS SECTION > CROSS 

SECTIONS… dialog allows you to select one surface and display only specific features or 
components. 
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Note: UPDATE CROSS SECTION and END AREA VOLUME are both on the “Cross 
Sections” dialog. 

 

Orphaned Graphics in Cross Sections 

In order to control the display of surface lines, components, and features in cross 
sections, the parent surface and parent geometry must be loaded.  Orphaned 
components and features are elements that can no longer by turned on or off for 
display using UPDATE CROSS SECTION.  See the section about Roadway Designer, 
Create Surface Known Issues for information on how to resolve or avoid orphaned 
graphics in cross sections.  

Recommend you 

leave all these 

boxes unchecked. 
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Volume 

End-Area Volume 

You do not have to have the surfaces (.dtm) loaded in order to compute end-area volumes 
if cross sections were previously cut. 

There is a setting in the “Surface Properties” dialog that can affect the computation of End-
Area volumes.  On the MAIN tab is the Type: field.  If the Type: is set to “Ignore”, the 

surface will not be used in the computation of End-Area volumes.  The default type for new 
design surfaces created by the Modeler is “Design”; the default type for new alternate 
surfaces is “Ignore”.  Whether this causes you problems in calculating end-area volumes or 
not, depends upon what you display in your cross sections.   

 

If you have displayed the components in the cross sections, you won’t typically need to 
display the subgrade surface in order to calculate end-area volumes.  The subgrade is 
determined in each section by starting at the left side of the design surface and following 
the rightmost path along the design surface and its components.  You can get the excavation 
and embankment volumes without ever displaying the subgrade surface (see below). 

 

 

If you choose to not display components and wish to calculate end-area volumes based 
upon the Alternate subgrade surface created by the modeler, you will have to change the 
surface properties before you display the subgrade surface in the section.  Select the surface 
and click the [Properties…] button on the GENERAL leaf of the “Create Cross Section” dialog 
box or go to SURFACE > SURFACE PROPERTIES… and set the Type: to “Design”.  Bentley 

The shape annotating 

the cut totally misses 

the SG (cyan); it is 

being ignored. 

Existing surface, finish 

grade surface, and 

components are 

displayed. 
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states in the InRoads Help, “If you have more than one “Design” surface in a section, they 
should not overlap.” 

 

Modeler 

Create Template… 

A template library seed file (.itl) has been created for ODOT use.  It is named ODOTseed.itl and is 
stored in the F:\ODOT_DATA\USERCFG\InRoads folder.  It is recommended that you copy the 
ODOTseed.itl file into your project directory in the Windows file system or import it into a 
ProjectWise project folder structure and rename it keynu.itl.  A shortcut in the Engineering 
folder on your desktop can be used to access the ODOTseed.itl file.  Double-click on the 
ODOT_User_Configuration shortcut to open a “Windows Explorer” dialog.  Then, open the 
InRoads folder. 

What’s in ODOTseed.itl? 

ODOT’s template library seed file contains point names to be assigned to points in your 
templates, three different categories of components – Roadbed, End Condition, and 
Advanced, several sample templates, and an empty “Template” folder for your own use, or 
not.   Roadbed and Advanced Components both include sub-folders containing components 
for assembling typical sections.  Each component in ODOTseed.itl has been assigned a style 
whose name begins with MAT-.  Only MAT- styles allow components to be displayed in 
cross sections and to have their quantities accumulated in end-area volume reports. 
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Structure of ODOTseed.itl 

Folders were created to separate roadbed components from end conditions and more 
advanced components.  Roadbed components are further divided by material/type to 
make it easier to locate the particular component you need.  An Overlay and Milling 
folder contains some basic leveling and milling components, and a widening template 
has been added to the samples.  The component names, within each folder, begin with 
either a sub-type or a material for sorting.  Descriptions have been added to most 
components to further describe their use or a setting.  Double-click on a component in 
the Template Library window to make it the Current Template so that you can read the 
Description. 
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Point Names 

The naming convention for point names was developed to meet three criteria:  

abbreviate to keep names short, 
make point name types that are easily identifiable, 
point name of similar types should be grouped together by name (alphabetically). 

Generally, each point name was constructed by stringing together letters or 
abbreviations, with no spaces, that describe the point using the order: feature + top (T) 
or bottom (B) + back (B) or face (F).  If there is a material designation, a hyphen and the 
abbreviation for the material are appended.  Abbreviations have the 1st letter 
capitalized.  Materials are Aggregate Base (AB), Base Course (BC), Subgrade (SG), 
Leveling (LV), and Milling (ML).  Points at finish grade do not have a material appended 
to the name. 

Examples of point names are TL, CurbTF, CL-SG, and EP-LV. 

Each point name is associated to a style which controls the display of the feature 
created from modeling the point along a corridor.  The style names used are described 
under Feature Styles and Named Symbologies in the Preferences section of this 
document.  When naming points, it is best practice to select a name from the Point 
Name List, which will also assign the correct style to the point.  The name may be edited 
after selecting it.  Adhering to this practice will assign styles to points that begin with 
Rdwy, Hy, Br, Rw, Surv, Traf, or Util.  When modeled, the points will create features 
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with those same styles.  Never assign an MAT- style to a point; MAT- styles are to be 
assigned to components only. 

Point Name List Known Issues 

Sometimes the “Point Name List” dialog will misbehave when it is opened.  Unlike the 
picture below, the dialog may appear very tall and extend below your task bar.  It will 
not resize and may get “lost” beneath the Create Template window.  If this occurs, try 
pressing the escape key on your keyboard, <Esc>, to dismiss the “Point Name List” 
dialog. Then reopen the “Point Name List” dialog.  If the “Point Name List” dialog 
continues to misbehave, call for support. 

 

Constraints 

The constraints placed on points in components in ODOTseed.itl were applied so that 
each point is fully constrained, except the attachment point, or parent, for each 
component.  On the top layer of each component, point constraints were generally set 
to horizontal, slope from the point one position closer to the CL.  Point constraints for 
points on other layers are generally set to horizontal, vertical from the points directly 
above.  This allows points on sub-layers to superelevate with the finish layer points, and 
also allows points on sub-layers to move in and out when a point on the finish layer is 
moved to widen or narrow a lane, for example. 
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Roadbed Components 

Roadbed Components contains the basic building blocks of a typical roadbed.  You can 
use the Multi-Layer Sections to assemble the lanes, medians, shoulders, and even 
shoulders with guardrail that make up the roadbed of a typical section.  Curb and Walk 
provides all of the standard curb sections and can be attached to lane and shoulder end 
points.  Should you need components for Islands, six different island components can be 
found in their own folder.  If you would like to assemble your own lanes and shoulders 
vertically, use the components found in the Base and Pavement folders.  The aggregate 
base shoulder wedge (rock shoulder) is also found in the Base folder.  Leveling and 
milling components may be found in the Overlay and Milling folder. 



ODOT InRoads® V8i User Guide 

 

March 2016 Oregon Department of Transportation Page | 71 
Engineering Applications Support Team 

 

 

The pictures below show the preview and the constraint view of the Islands Component 
– Island, Type CA Mountable.  The attachment point is named CL-SG and is intended to 
be attached to the subgrade layer.  This component sits atop the paved surface.  The 
vector-offset constraint was used in the curb portion because of how the curb is 
described in the ODOT Standard Drawings. 

 

 

 

 

 

  

Island, Type CA Mountable 
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The Curb & Gutter components, in the Curb and Walk folder, may require the use of a 
null point named nominalEP to define the horizontal location of the top face of curb 
(CurbTF).  When attaching these components to a template, do not snap to existing 
components.  Important constraints will be lost if points are deleted because of merging 
during attachment.  Drag these components into your template and drop them out in 
space.  Then, move the entire component into place by moving the TL1 point on the 
Curb & Gutter component and snapping it to the TL point on the wearing course 
component for the travel lane already in your template.  Manually merge the TL points, 
deleting TL1.  Edit the EP on the wearing course component and remove its constraints 
to free it up.  Move the EP point and snap it to the EP1 point on the Curb & Gutter 
component.  Manually merge the EP points that are now coincident and delete the EP 
point which had no constraints.  Finish up by renaming EP1 to EP. 

 

 

 

  

Curb & Gutter, Standard 
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The Curb and Walk folder also includes drainage curbs.  The Drainage Curb, Under 
Guardrail is shown below.  There are two unconstrained points for the drainage curbs.  
These components are designed to have CurbBF-D attached to the face of guardrail 
point on the finish layer.  After attaching the component to the template, right-click on 
the TL point of the drainage curb component, choose Move Point and snap it to the 
edge of travel lane point on the template.  Finally, right-click on the edge of travel lane 
points and merge them, retaining the original point name.  Now when the shoulder is 
superelevated, the drainage curb will retain its angle relative to the roadway. 

 

 

 

  

Drainage Curb, Under Guardrail 
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Milling and Leveling components are included in a folder named Overlay and Milling.  
These are very powerful components that have a very simple appearance. 

 

The components have been created symmetrically, 12’ wide on each side with slopes of 
2%.  When these components are assembled into a template with a lane component to 
be used for widening, the points on the Leveling or Milling component will merge with 
the points already named TL in the template.  The milling component is identified as a 
“stripping component” and its area will not be included in cut volume calculations.  If 
the milling component uses the bottom of an asphalt lift (wearing course) as its base 
component, it is possible to have the asphalt lift material incorrectly contribute to the 
cut volume.  To avoid that, when displaying components is cross section for end-area 
volumes of leveling and milling, do not display wearing course components. 

The template below has been added to the Sample Templates folder to illustrate one 
method for using the component named Milling and Leveling.  Open the template and 
click the [Test…] button to see the Milling and Leveling component function. 
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Advanced Components 

The Advanced Components folder contains components that you may wish to model in 
your roadway, such as barriers and walls.  The barrier components use angle, distance 
constraints for the base of the barrier to match the slope of the roadway in 
superelevated sections.  When these barrier components are displayed in cross sections, 
the bottom of the barrier will lie at the slope of the roadway.  The Barrier folder also 
includes Type 2A Guardrail, Guardrail Rock Shoulder, and Guardrail Flare Shoulder. 

Placement of the Concrete Barrier component in a template is similar to that of 
drainage curb.  The Concrete Barrier components are designed to have BarBF attached 
to the face of barrier point on the finish layer.  After attaching the component to the 
template, right-click on the TL point of the barrier component, choose Move Point and 
snap it to the edge of travel lane point on the template.  Finally, right-click on the edge 
of travel lane points and merge them, retaining the original point name.  Now when the 
shoulder is superelevated, the barrier will retain its angle relative to the roadway. 

 

 

  
Concrete Barrier 
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End Conditions 

The End Conditions folder contains standard cut and fill slopes, as well as drainage 
ditches, and media filtered slopes.   The ODOT Standard Cut & Fill end condition will 
attempt all of the end conditions, and checks for the 1: 6 cut condition with a 0.5 foot 
ditch first.  There is also a Berm end condition which checks for a 1:4 “false” cut at the 
back of the berm first.  “Use Feature Name Override” has been toggled on for all catch 
points in the standard end condition components.  The feature name override will use 
the same feature name for whichever end condition is successful, either SSC or SSF. 

 

 

 

 

 

 

  

ODOT Standard Cut & Fill 

Berm Cut & Fill 
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Constraint Labels 

Many points have constraints that are labeled in their Point Properties.  The labels can 
have their values changed during design processing using Parametric Constraints.  
Parametric constraints are applied in the Roadway Designer at the time that the 
template is processed.  By using parametric constraints, you can use one template and 
simply identify the station range for different values of depths or widths to be applied.  
The values do not have to be the same at the start and stop stations, so you can use this 
to create tapers as well.   

You can assign labels to more than just horizontal and vertical constraints.  For example, 
you could transition a side slope from 1:6 to 1:3 across a station range, by labeling a 
slope constraint and applying parametric constraints during modeling.  Some of the 
labels that are included in the components in ODOTseed.itl that you can set Parametric 
Constraints on are: 

AggDepth 
BaseCourseDepth 
CandGWidth 
Exposure 
GutterSlope 
GutterThickness 
LaneWidth 
-LaneWidth 
MedianWidth 
-MedianWidth 
PavedShoulderWidth 
-PavedShoulderWidth 
WalkWidth 
-WalkWidth 
WearingCourseDepth 

The horizontal labels receive a negative or minus label when they are placed using the 
“Mirror” option.  Labels do not increment like point names.  Two travel lanes placed 
next to each other with points TL_L and TL1_L, for example, will have the same label for 
LaneWidth.  If parametric constraints are to be used to change the width of only one 
lane, then one of the labels must be edited. 

Templates 

If you take advantage of using parametric constraints for setting widths, depths, and 
creating tapers, you should see a large reduction in the number of templates required to 
model a roadway.  Descriptive names, good descriptions, and organization are still 
extremely important in the template library. 

Template names are left up to the designer’s preference.  Consistency in naming will 
benefit yourself and others, because it is easy to use the Template Library Organizer to 
copy templates from one template library to another.   Designers should be considerate 
of those who may have to follow their work by using descriptive names, taking the time 
to fill in the Description field.  Use the right-click Template Documentation Link… or 
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Library Documentation Link… to “attach” a link to another file where you can be more 
verbose in your explanation. 

 

The empty “Template” folder was left in the ODOTseed.itl for your use.  You may create 
sub-folders or simply create your new templates in the “Templates” folder. 

Only left side components have been constructed in ODOTseed.itl.  It is intended that 
you will use the generic components, “Apply Affixes”, and mirror or reflect to place the 
components into your templates.  The Template Options have been set to “Apply 
Affixes” by default.  The affixes that are applied to point names are suffixes  _L and _R.  
The affixes will be applied when the components are placed into the Current Template.  
Components have been designed with the concept that you will build templates from 
the center, outward.  Point names on the inner side of every component will be 
replaced with corresponding point names on the outer side of the component they are 
attached to (merged). 
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One of the things to pay special attention to is those merging point names.  If they don’t 
merge, it could be because one of the points has a slight offset (0.01’) from the point 
directly above it.  Some of the components (Aggregate Base Sidewalk, for example) 
purposefully have a slight offset on the outer points.   If the offset were not there, one 
of the points may not be triangulated in the alternate surface that may be ultimately 
created.  Look at the Sample Template “4 Lane w/Median & Curbs” and see how 
WalkTB_L and WalkBB1_L are both part of the alternate SG surface and are not directly 
over the top of one another, so that they will triangulate correctly. 

 

 
Tip: InRoads will not triangulate points that are directly above one another.  It will 
treat the features as crossing breaklines and drop one of them from the triangulation.  

 

 
Caution: Alternate surfaces should be carefully checked prior to using for calculating 
quantities to ensure that they have triangulated correctly. 

 

Be extremely careful if you intend to use an alternate SG surface for calculating triangle 
volumes.  In the image below, end-area volumes will be calculated with a subgrade that 
runs along the bottom side of the sidewalk aggregate base and curb components to the 
bottom of the aggregate base.  Triangle volume will be based upon the triangulated SG 
surface (dashed red line), which you can see is missing a triangulation point or two and 
cuts through the drain curb. 

 

Building templates with curb and walk will likely require some editing of the aggregate 
base and base course components to get them under the curb and wrapped around the 
bottom of curb – see the sample templates in the ODOTseed.itl. 

Templates Known Issues 

Creating Your Own Components 

When you create new components (you will need to do this sooner or later), make sure 
that you turn off “Apply Affixes”.  The Template Options have been set to “Apply 
Affixes” by default.  And that will work well for building templates.  When building 
components, though, it would have the effect of placing the suffix “_L” or “_R” on the 
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point name in the new component.  Then when you use the component to build a 
template, another affix will be applied and you’ll get point names like EP_L_L and 
SGSh_R_L.  Always take the time to assign an MAT- style to components that you 
create.  The MAT- styles were created especially for components so that they display in 
cross sections and contribute to end-area volumes. 

Roadway Designer… 

Naming Convention for Roadway Design Files (.ird) 

There are no hard and fast rules for naming and organizing Roadway Design Files (.ird).  It is 
recommended that you store them in your project folders with all your other InRoads files 
and use the keynu.ird naming convention. 

Within the Roadway Design File, you will create corridors to model your alignments or 
features.  There is no Description field for the corridors, but resist the urge to be overly 
descriptive with the name.  The corridor name can affect both the surface name and feature 
names within the surface, so you’ll probably want to keep it short.  The “Manage Corridors” 
dialog displays both the name of the alignment that the corridor was created for and the 
beginning and ending stations. 

Parametric Constraints 

To change the values on labels that were set on components in the template, use TOOLS > 
PARAMETRIC CONSTRAINTS….  The parametric constraints are specific to the active corridor 
and are saved in the InRoads Designer File with that corridor. 

Superelevation 

Superelevation is an application of point controls.  A clarification in the ODOT Highway 
Design Manual allows us to take advantage of InRoad’s “Create Superelevation Wizard” to 
create superelevation control lines that achieve a smooth super gradient while pivoting 
about the low edge of travel lane.  If you did not enter the maximum ‘e’ value for each curve 
in the geometry, the AASHTO Wizard gives you access to the Rate Calculator, where you can 
edit and save that information.  The recommended workflow is to use SUPERELEVATION > 

CREATE SUPERELEVATION WIZARD > AASHTO… to create the superelevation control lines.  
This is shown more completely in the Workflows section. 

Point Controls 

Point controls are found under CORRIDOR > POINT CONTROLS… and are used to modify the 
behavior of points in a template.  Point controls will override any constraints on the point in 
the template.  You can set the control mode to be horizontal, vertical, or both.  Point 
controls can be quickly disabled with a single check box.  A real advantage is that point 
controls are not limited to any particular portion of the template – you can even use point 
controls on the catch point in an end condition.  You can use point controls on any point in 
the template to create tapers, match existing, or model ditches.  If a point’s control type is 
defined as superelevation, the control line can be edited in the Superelevation Display 
Window.  Editing superelevation control lines is a method you could use to match existing 
superelevations at tie-ins. 
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Create Surface 

You will notice in the dialog shown below, that the Name field is grayed out.  When you 

check the option “New Surface for Each Corridor”, the name of the surface is automatically 
determined from the corridor name. 

 

 

The main reason “New Surface for Each Corridor” is checked by default is because this 
setting will create the shortest feature name possible and the feature names are used in 
reports.  When the feature name also includes the corridor name, the names just get too 
long for good looking reports. 

Create Surface Known Issues 

Orphaned Graphics in Cross Sections 

It is common to re-create design surfaces several times, updating cross sections after each 
creation, to analyze and compare the results to what is seen in the Roadway Designer.  It is 
very easy to create orphaned graphics in the cross sections when “Empty Design Surface” is 
checked on.  Orphaned components and features are elements that can no longer by turned 
on or off for display using UPDATE CROSS SECTION.  In order to control the display of 
surface lines, components, and features in cross sections, the parent surface and parent 
geometry must be loaded.  Re-creating the surface may establish a new, unique identifier on 
the components and features that does not match the previously created surface identifier, 
effectively disinheriting the graphics.  Orphaned graphics may be manually removed from 
cross sections using MicroStation commands, or a new set of cross sections may be created 
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and the old set deleted to resolve the situation.  One way to avoid creating orphaned 
graphics is to recognize that you will be creating a new surface with the same name and turn 
off the display of the original surface, components, and crossing features prior to using 
Create Surface with “Empty Design Surface” checked on.  Then UPDATE CROSS SECTION 
may be used with the mode “Display On” selected to see the new data. 

Alternatively, the General Options and Feature options for Duplicate Names could be 
modified from the defaults seen above, so that when new features and components are 
created, the names and identifiers are retained, with the result that the graphics already 
drawn in the cross sections may be refreshed to see the changes using UPDATE CROSS 
SECTION (mode set to “Refresh”).  To retain the names and IDs of features and components 

in the surface, uncheck “Empty Design Surface” and set the Duplicate Names option to 
“Modify”. 

 

The caution here is that it is possible to retain features and components in the design 
surface that you may have removed from your templates.  If a corridor has been modified to 
not create a feature that was previously created, and you do not empty the design surface 
during the re-creation, that old feature still exists in the re-created surface.  The old 
components also still exist in the re-created surface.  The surface may not triangulate 
correctly.  The surface line, components, and features, while not orphaned, may not update 
their display correctly.  If you are removing points or components from the templates and 
re-creating surfaces, it is recommended that you empty the design surface.  

Corridor Name Length Limit 

If the corridor name exceeds 28 characters, you have the potential to create a surface with a 
name that exceeds the surface display name length limit when creating alternate surfaces.   
See the section on Surface Display Name Length Limit for more information. 

Tools 

XML Reports 
There are several commands that generate XML data files.  The main location is TOOLS > XML 

REPORTS, however, another key location is EVALUATION > CROSS SECTION > CROSS SECTION 
REPORT…  

There are three steps to producing XML reports. 
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1. Generate the XML data. 
2. View the XML data in the appropriate style sheet (.xsl) in the Report Browser. 
3. Save the report from the Report Browser using FILE > SAVE AS… and choosing (*.html, 

.doc, or .xls), or right-clicking and exporting to Microsoft Excel or OneNote. 
 

 

 

When the active DGN file is stored in a ProjectWise datasource, the FILE > SAVE AS… 
command on the “Civil Report Browser” causes ProjectWise dialogs to open first.  The folder 
location on the ProjectWise “Save As” dialog will be blank, though.  The default path for saving 
reports is ignored and ProjectWise opens the “Save As” dialog at the top of the Documents 
folder in the datasource.  Always use the [Change…] button, and then the “Select Folder” dialog 
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to select the ProjectWise location, or use the [Cancel] button to save reports in the Windows file 
system. 

 

Some InRoads files are written in XML format, so generating the data may be as simple as 
loading the file into the Report Browser.  Files that can be opened in the Report Browser and 
reported on include preference files (.xin), template libraries (.itl), and roadway design files 
(.ird). 

Other data must be first generated in XML format by launching one of the Report dialogs found 
in TOOLS > XML REPORTS or EVALUATION > CROSS SECTION > CROSS SECTION REPORT…   
Once the XML data is generated, the Report Browser is automatically launched and a style sheet 
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is opened.  If the format is inappropriate for the data – it will be obvious.  You’ll see the 
formatting codes, which looks like a lot of information in between the symbols ‘<’ and ‘>’.  If you 
don’t have any XML data loaded, well then, you’ll see nice blank reports or report titles and 
headers only, no matter which style sheet you select. 

 

Folder 

Name Report Name Description 

Clearance Clearance.xsl 

Tools > XML Reports > Clearance…  This report creates clearance 

information for multiple alignments, features, and cogo points. The 

clearance is computed with respect to a particular alignment or 

feature, identified in the From group box. STA, OFF, N, E, EL, RAD 

DIR 

Evaluation CrossSectionStakingTable.xsl 

Evaluation > Cross Section > Cross Section Report…  Displays 

station, offset, and elevation data for the selected surface.  

Evaluation Basicvolume.xsl 

Evaluation > Cross Section > Cross Sections…End-Area Volumes  

Displays Station, Cut Factor, Cut Area, Cut Volume, Adjusted Cut, Fill 

Factor, Fill Area, Fill Volume, Adjusted Fill, Mass Ordinate 

Evaluation TriangleVolumes.xsl 

Evaluation > Volumes > Triangle Volumes…  Displays Mode, Original 

Surface, Design Surface, Factors, Cut, Fill, Net cu ft and cu yd 

Evaluation TriangleVolumeByStation2.xsl 

Evaluation > Volumes > Triangle Volume By Station…  Displays 

Station, Cut Factor, Cut Area, Cut Volume, Adjusted Cut, Fill Factor, 

Fill Area, Fill Volume, Adjusted Fill, Mass Ordinate, Grand Totals 

Geometry HorizontalAlignmentReview.xsl 

Tools > XML Reports > Geometry…  Displays information on all 

elements in the alignment. 

Geometry 

HorizontalAlignmentCurveSetRevi

ew.xsl 

Tools > XML Reports > Geometry…  Displays information on all 

elements in the alignment, but groups them based on the curve sets 

in the alignment. 

Geometry VerticalAlignmentReview.xsl 

Tools > XML Reports > Geometry…  Displays information about 

vertical alignments of the selected horizontal alignment. 

Geometry ListCoordinatesStation.xsl 

Tools > XML Reports > Geometry…  Reports on point coordinate 

data for all or a portion of multiple alignments or cogo points.  STA, 

PT TYPE, E, N, EL 

StationOffset 

(StationBase) TransverseFeature.xsl 

Tools > XML Reports > Station Offset…  This report creates an XML 

report data file that contains station base/station offset data for 

selected alignments or features. FEATURE NAME, STA, OFF, EL, N, E 
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The big question might be, “How do I know which style sheet is appropriate for which type of 
data?” 

You will notice a correlation between the choices in the TOOLS > XML REPORTS commands and 
the folder structure for the style sheets in the Report Browser.  It’s not a one to one correlation, 
but you should get the general idea.  Once the XML data is loaded, you can double-click to open 
the different folders and then single-click on a style sheet to view your data in that style.  A 
single-click will do it.  Be patient while all of your data is redisplayed.  It may take a minute. 

For example, if you are producing Clearance reports, well then try the different style sheets in 
the Clearance folder in the Report Browser.  If you are creating reports from EVALUATION > 
CROSS SECTION > CROSS SECTION REPORT…, look in the Evaluation folder for the different 

style sheets that area appropriate for that data.  The Evaluation folder contains style sheets for 
Cross Section reports as well as Volume reports. 

View XML Reports 

Report Browser 

When the Report Browser is open (TOOLS > VIEW XML REPORTS…), you have the ability to 
control the precision and format of the data that is displayed by selecting in the Report 
Browser menu TOOLS > FORMAT OPTIONS….  The initial values in the “Format Options” 
dialog (shown below) are set by the logon batch file.  If you make changes to the Format 
Options, those changes are immediately written to your registry and are “permanent” until 
you change them in this dialog. 
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Reports Known Issues 

Style Sheet Help 

The Style Sheet Help should display the Notes section in the active style sheet, hopefully 
explaining the requirements for producing the XML data for that style sheet.  
Sometimes the “Style Sheet Help” dialog won’t open. 

InRoads Help will tell you that if you are having difficulty getting results when selecting 
an XSL file that you can right-click the style sheet and select Style Sheet Help.  The issue 
is that unless you have successfully loaded any XML data, the “Style Sheet Help” dialog 
doesn’t open.   The easiest way to get the “Style Sheet Help” dialog to open is to load 
a file into the Report Browser that is already written in XML – like your project .itl or .ird.  
Once an XML data file is open, the “Style Sheet Help” dialog will open.  Right-click on the 
style sheet (.xsl) and choose Style Sheet Help. 

Tracking>Tracking… 

There are four groups of tracking preferences.  Only the ODOT preference is configured for 
dynamic display of graphics with text sizes suitable for immediate viewing.  The Const_* 
preferences (used to annotate tapers and driveways for contract plans) are configured for 
adding annotation scale in 1“=100’ scale models.  RW_* and Surv_* preferences (used to 
annotate access and easements) are all configured for adding annotation scale in 1”=50’ scale 
models.  The preferences are accessed through the [Settings…] button on the “Tracking” dialog 
as shown below.  For the annotation scale preferences: Const_*, RW_* and Surv_*, typical 
usage is to load the preference, activate tracking, click on a point, then add annotation scale to 
see the annotations.  These annotations will respond to the rules of annotation scale by 
changing size when the drawing scale is changed. 
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The preferences with 0 offset values may be used without adding annotation scale by setting a 
GLOBAL SCALE FACTOR for Text of 1200 for the Const_* preferences and 600 for the RW_* 

and Surv_* preferences.  If the TOOLS > GLOBAL SCALE FACTORS is used, instead of adding 

annotation scale, your annotations will be immediately seen in the drawing, but will not respond 
to drawing scale changes. 

 

Tracking>Horizontal Alignments 

The horizontal alignment information will display in the status bar of the InRoads Explorer 
window.  The amount of information is hard-coded and cannot be changed.  New in V8i is the 
display of the Grade and the display of all of the information in a text node that follows the 
cursor in the view window. 
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The text node that follows the cursor cannot be placed as graphics in the file; it is just another 
way to display the information.  The active text attributes are used for display and the text 
responds to the annotation scale if the Annotation Scale Lock is toggled on.  The display cannot 
be turned off, but if it distresses you to see it, turning on the Annotation Scale Lock will typically 
cause the text to expand outside the range of your view window.  In other words, to make the 
text display so large that you can’t see it, turn the Annotation Scale Lock on. 

Application Add-Ins 

Application add-ins are optional components or additional tools that work within InRoads. The 
list of add-ins can be accessed using the TOOLS > APPLICATION ADD-INS menu option to 

bring up the following dialog. 

 

Clicking on an add-in name provides a description of the add-in in the middle portion of the 
dialog as shown above, and the lower portion of the dialog will indicate which applications (IE: 
InRoads, Storm and Sanitary, etc.) the add-in can be used with. Selecting (clicking in the check 
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box left of the name) and then clicking [OK] will toggle an add-in on to be loaded when InRoads 
is launched.  

The application add-ins that you choose to load are saved in the Windows Registry as part of 
your personal profile. Again, this translates to “user specific settings”.  If your neighbor has 
menu options available that you don’t have, it is probably a result of them having loaded 
additional add-ins. 

Many of the available add-ins are translators that facilitate sharing data between various design 
software.  

Copy Preferences…  

The Copy Preference Add-In has not been loaded by default, but may be of interest if you 
would like to share custom preferences or styles between preference files (XIN).  This tool 
copies or merges Styles and Preferences from a selected XIN file into the active XIN file.  It 
also copies Named Symbologies. 

Product Add-Ins 

It is possible to load other InRoads products after running InRoads Lite or launching InRoads from 
the desktop shortcut.   TOOLS > PRODUCT ADD-INS will bring up a dialog where you may load 
InRoads Survey or InRoads Storm and Sanitary.   

 

Because these products are licensed separately, “Persist Product Add-Ins on Exit” is effective only 
until the next time you log in to Windows. 
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Workflows 
The following workflows illustrate the steps to perform typical tasks using data stored in the 
Windows file system. 

Add Annotation Scale to Features Displayed from DTM 

In the Geometry Styles and Symbologies section, it was mentioned that InRoads will not apply 
annotation to annotation cells or text that it places.  After displaying features from a DTM, you 
will notice that point features such as inlets or pavement markings appear as tiny dots – possibly 
so small that you cannot see them.  It is necessary to use the Add Annotation Scale button, [+A], 
so that the cells and text respond to the drawing scale. 

 

The image below on the left shows graphics after displaying features from an existing ground 
DTM.  The image on the right was achieved by clicking [+A] to add annotation scale. 

         

Create a DGN Basemap With Cells That Respond to Annotation Scale – The Steps 

Work in a separate model for creating a basemap to avoid adding annotation scale where it 
is not appropriate.  Create a new design model from seed3d.dgn. 

1. In InRoads, use SURFACE > UPDATE 3-D/PLAN SURFACE DISPLAY… or SURFACE 
> VIEW SURFACE > FEATURES… to display the features in the model.  A filter 
named BASEMAP TOPO may be applied with the Feature Filter Lock on (as seen 
below), to limit the display to those features that are normally displayed on a 
basemap.  Network points and terrain breaklines are filtered out, for example. 
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2. In MicroStation, if the basemap graphics are the only graphics in the model, click the 
Add Annotation Scale button, [+A].  You can limit the effect of Add Annotation Scale 
by making a selection set of only those graphics you wish to change. 

 

Once annotation scale has been added, cells may be rotated to the correct 
orientation. 
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Add Annotation Scale to InRoads Plan View Alignment Annotations 

The preference set configured for contract plans annotation (named ODOT-Plans) uses 
symbologies that are defined as print size.  When annotation scale is added to a selection set of 
the alignment graphics, the text and cells are scaled up according to the drawing scale of the 
model, so that when they are scaled down during printing, they print at the correct size.  Station 
leaders and ticks do not respond to annotation scale because they are not cells.  To shorten the 
leader lines and ticks, you would use a preference name that ends with _Inch50 when 
annotating stationing for a 1”=50’ scale plan set.  Similarly, when you need stationing for a 
1”=200’ drawing, you would load a preference name that ends with _Inch200 to lengthen 
leaders and ticks. 

InRoads annotation for Right of Way and Survey drawings is configured to be used in models 
with drawing scale set to 1”=50’.  The RW_PrimInch100 preference can be used when 
stationing and alignment in a 1”=100’ RW drawing. 

1”=100’ Alignments for Contract Plans – The Steps 

Work in a separate model for plan view annotations to avoid adding annotation scale where 
it is not appropriate.  Create a new design model from seed3d.dgn or seed2d.dgn.  Ensure 
the drawing scale is set to 1”=100’.  Note that in the example below, the Name indicates the 
contents of the model and the Description indicates the scale.  You may choose to put an 
indication of the drawing scale in the Name; however, no special characters are allowed in 
the model Name field. 
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Use three commands from GEOMETRY > VIEW GEOMETRY, and with each command load the 

ODOT-Plans preference set (ODOT-Plans is configured for use in 1”=100’ drawing scale 
models). 

 

 

 

 

 

1. GEOMETRY > VIEW GEOMETRY > HORIZONTAL ANNOTATION… This command will 
draw the alignment itself and annotate the tangent bearings. 

 

2. GEOMETRY > VIEW GEOMETRY > STATIONING… This command will place leaders, 

ticks, major stationing, and cardinal point stationing.  Stationing will also place the 
alignment name abbreviation at regular, cardinal, PI, and station equation stations if 
you enter the abbreviation in the Prefix field. 

Enter alignment 

name and press 

the <Tab> key. 

Load the ODOT-

Plans 

preference. 
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3. GEOMETRY > VIEW GEOMETRY > CURVE SET ANNOTATION… This command will 
place the curve data which will require a small amount of editing for ODOT’s 
standard format. 

After running the three View Geometry commands, the alignment will appear as below. 

 

The station text and curve data appears as small dots because it is scaled down 1200 times.  
Now the annotation scale must be added.  Make a selection set of all of the alignment 
graphics, then click the Add Annotation Scale button, [+A]. 

  

 

Make final edits to the curve data.  If there are unequal spirals, the command TOOLS > 
CONVERT PENCIL TO INK… or Remove User Data… may be used on a selection set of 
the alignment graphics to “freeze” them.  Then, annotate the curve set data only, again, 
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using the ODOT-Plans_unequal_spirals preference; use station limits to annotate only 
the curve set with the unequal spiral.  Use the combination of the two sets of curve data to 
edit the final set, deleting what is not required. 

1”=50’ Alignment for Contract Plans – The Steps 

Work in a separate model for plan view annotations to avoid adding annotation scale where 
it is not appropriate.  Create a new design model from seed3d.dgn or seed2d.dgn.  Set the 
drawing scale to 1”=50’.  Name the model and describe it, see example below. 

  

Use the three commands from GEOMETRY > VIEW GEOMETRY, as shown in the example 

above, and with each command load the ODOT-Plans preference set, except for 
Stationing.  For Stationing, load the preference set named ODOT-PlanSheetInch50. 

 

 

The image above shows shorter leaders and ticks that will be required for a drawing scale of 
1”=50’. 
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The image above shows the alignment after adding annotation scale in a 1”=50’ drawing 
scale model. 

Steps for 1”=200’ are similar to steps for 1”=50’.  View Geometry and Add Annotation Scale 
in a drawing scale of 1”=200’.  When Stationing, load the ODOT-PlanSheetInch200 
preference.  After annotation scale is added the alignment annotations, leaders, and ticks 
will all appear the correct size. 

1”=50’ RW Drawings – The Steps 

Work in a separate model for plan view annotations, to avoid adding annotation scale 
where it is not appropriate.  Create a new design model or file from seedRW2d.dgn.  Set the 
drawing scale to 1”=50’.  Name the model and describe it. 

Use the three commands from GEOMETRY > VIEW GEOMETRY, as shown in the examples 

above, and with each command load the RW_Prim preference set.  After adding 
annotation scale, the RW_Prim preference produces geometry annotation as shown below. 

 

 

 

Steps for 1”=100’ RW alignment annotations are similar to steps for 1”=50’.  View Geometry 
and Add Annotation Scale in a drawing scale of 1”=100’.  When Stationing, load the 
RW_PrimInch100 preference.  After annotation scale is added the alignment annotations, 
leaders, and ticks will all appear the correct size. 

Vertical Alignment Annotations in Profile Windows 

The ODOT-Plans preference for Vertical Annotation in profile windows uses symbologies that 
are sized correctly for placement in 1”=100’ profile sheets without adding annotation scale.  The 
workflows that follow illustrate how to use the ODOT-Plans preference set for vertical 
annotation in combination with three different preferences (Prof_1’’=100’, Prof_1’’=200’, and 
Prof_1’’=50’) for profile creation, and applying a GLOBAL SCALE FACTOR where necessary.  
When using the preferences for profile creation it will be beneficial to have an idea of the 
elevation limits of your data.  Entering limits for elevation and station in the Controls category 



ODOT InRoads® V8i User Guide 

Page | 98 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

 

 

will ensure that the profile window created will entirely fit inside a profile sheet border and that 
station and elevation labels will also be displayed close enough for copying into the sheet. 

1”=100’ Profile and Vertical Annotation for Contract Plans – The Steps 

Work in a separate model for profiles to avoid adding annotation scale where it is not 
appropriate.  Create a new design model from seed3d.dgn or seed2d.dgn.  Ensure the 
drawing scale is set to 1”=100’.  (The only thing affected by annotation scale in this workflow 
is the placement of the profile sheet border.) 

Use the command EVALUATION > PROFILE > CREATE PROFILE… and load the 
Prof_1’’=100’ preference.  Open the Controls category for Limits and replace the 0 to 50 
foot elevation limits with a 50 foot limit appropriate for your data.  Replace the 0+00 to 
13+00 station limits with a 1300 foot range appropriate for your vertical alignment. 

 
Once the profile window is created, the vertical geometry may be annotated.  Use the 
command GEOMETRY > VIEW GEOMETRY > VERTICAL ANNOTATION… .  Load the ODOT-

Plans preference set, use the target button or ensure that you have the correct Profile Set 
selected and click [Apply].  
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The result is an annotated profile that fits within an 11”x17” border with annotations and 
labels that are the correct size for 1”=100’ prints. 

 

Target or 

select the 

Profile Set. 

Load the ODOT-

Plans 

preference. 
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1”=50’ Profile and Vertical Annotation for Contract Plans – The Steps 

Work in a separate model for profiles to avoid adding annotation scale where it is not 
appropriate.  Create a new design model from seed3d.dgn or seed2d.dgn.  Ensure the 
drawing scale is set to 1”=50’.  (The only thing affected by annotation scale in this workflow 
is the placement of the profile sheet border.) 

Use the command EVALUATION > PROFILE > CREATE PROFILE… and load the 
Prof_1’’=50’ preference.  Open the Controls category for Limits and replace the 0 to 25 foot 
elevation limits with a 25 foot limit appropriate for your data.  Replace the 0+00 to 6+50 
station limits with a 650 foot range appropriate for your vertical alignment. 

 

Once the profile window is created, the vertical geometry may be annotated.  Because the 
ODOT-Plans preference set is designed for 1”=100’ annotation, you will apply a Global 
Scale Factor of 0.5 for Text and Cells to adjust the annotation before annotating.  Use the 
command TOOLS > GLOBAL SCALE FACTORS…, enter 0.5 in the fields for “Text” and “Cells”, 
and click [Apply]. 

 

Now, use the command GEOMETRY > VIEW GEOMETRY > VERTICAL ANNOTATION… .  Load 
the ODOT-Plans preference set, use the target button or ensure that you have the correct 
Profile Set selected and click [Apply], exactly as shown above for 1”=100’.  
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The result is an annotated profile that fits within an 11”x17” border with annotations and 
labels that are the correct size for 1”=50’ prints. 

 

Steps for 1”=200’ are similar to the steps for 1”=50’.  When creating the profile, load the 
Prof_1’’=200’ preference and replace limits – 100 foot elevation range, 2600 foot station 
range.  Prior to viewing the vertical annotation, use a Global Scale Factor of 2 for text and 
cells. 
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Grade Reports 

While it is not required to run roadway modeler to create a design surface, in this workflow, a 
corridor was modeled to create features from points in templates.  When using Create Surface 
in the Designer, all of the features are stored in the design surface whether they are 
triangulated or not.  To get the report, we produce XML data about the feature at specified 
stations along the alignment.  We will be generating cross section XML data, and it is the cross 
section intervals and special stations that provide the station data.  In order to provide data 
about the location of the features, the features are required to be displayed in the cross 
sections. 

Grade Reports - The Steps 

Display cross sections at the interval you wish your grade reports to be.  Use the CONTROLS 
leaf to add special sections such as Cardinal stations.  Other stations can be added as 
Perpendicular stations using the CUSTOM leaf. 
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Don’t include anything extra during the creation of the cross section set. 

 

Display the features in the cross sections that you want to display in the grade report using 
the UPDATE CROSS SECTIONS leaf.  All of the features should be in the design (finish grade) 

surface. 

 

  

Leave all boxes 

on Include leaf 

unchecked. 
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Proposed features that are created from standard ODOT components have styles defined so 
that they all display as plus signs ‘+’.  The feature has to be displayed in the cross section.  If 
it fails to display because of a style definition, the feature will not appear in the report. 

 

Create the XML data file by selecting EVALUATION > CROSS SECTIONS > CROSS SECTION 
REPORT….   

 

Always use the target button to select the Cross Section Set.  Then select only the design 
surface (finish grade) in the Include Surfaces section.  Select nothing else and click the 
[Apply] button to generate the report on the features that you displayed in the cross 
sections. 
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When the Report Browser opens, select Evaluation\CrossSectionStakingTable.xsl. 

 

Verify that the precision and formats are set the way you wish to see them by selecting 
TOOLS > FORMAT OPTIONS… on the Report Browser menu.  When you close the “Format 
Options” dialog, the settings are written to your registry and will be retained when you open 
other style sheets and when you re-launch InRoads. 
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Use FILE > SAVE AS… in the report browser to save the report as XLS File (*.xls). 

 

End-Area Volume Reports 
End-Area volume reports are also generated from the cross sections.  Because of the method 
that InRoads uses to determine the subgrade, it is imperative that the components be displayed 
in the cross sections.  The MAT- group of styles is what allows components to be displayed in 
cross section.   The subgrade is determined starting at the left side of the design surface and 
following the rightmost path along the surface and its components.  This path is then compared 
against the existing surface and any substrata to compute the areas of volume. 

End-Area Volume Reports - The Steps 

Display cross sections at the interval you wish for your end-area volume calculations.  Again, 
just as described in the grade report workflow, don’t include anything extra during the 
creation of the cross section.  This sample workflow uses that same cross section set. 
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Display the components from the finish grade surface in the cross sections using 
EVALUATION > CROSS SECTIONS > CROSS SECTION… UPDATE CROSS SECTIONS leaf. 

 

Only components whose style is assigned to an MAT- style will display in cross section.  
Guardrail components in ODOTseed.itl are purposefully assigned a Rdwy style that will not 
display the guardrail component in cross section.  The reason for this is that the Guardrail 
post will normally punch down through the bottom of the aggregate base component which 
affects the calculated subgrade line and the end-area volume.  



ODOT InRoads® V8i User Guide 

Page | 108 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

 

 

Create the XML data file by selecting EVALUATION > CROSS SECTIONS > CROSS SECTION… 
END-AREA VOLUMES leaf, and checking the “Create XML Report” box.  Only the Existing 

surface and the finish grade Design surface need to be checked.  InRoads uses the 
components to determine the subgrade. 
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When the Report Browser opens, select Evaluation\BasicVolume.xsl to get a Cut/Fill end-
area report by station with grand totals of cut and fill volumes on the last page. 

 

Select Evaluation\Volumes.xsl (see below) to get a Cut/Fill and Material Type end area 
report by station with grand totals of the cut and fill volumes and the total volume of each 
material on the last page. 

Use FILE > SAVE AS… in the report browser to save the report as XLS File (*.xls). 
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Triangle Volume Reports 

Triangle volume reports are generated from the loaded surfaces.  While end-area volumes must 
involve a “Design” type surface and “Existing” type surface, triangle volumes may be computed 
between any types of surfaces and nothing need be displayed. 

Triangle Volume Reports - The Steps 

Create the XML data file by selecting EVALUATION > VOLUMES > TRIANGLE VOLUME…..  
Select the existing surface for “Original Surface” and the alternate SG surface for the 
“Design Surface” and click the [Add] button and then [Apply]. 

 

When the Report Browser opens, select Evaluation\TriangleVolumes.xsl to get a Cut/Fill 
Triangle Volume Report with totals of cut and fill. 

 

Use FILE > SAVE AS… in the report browser to save the report as XLS File (*.xls). 
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Triangle Volume By Station Reports 

Triangle volume by station reports are also generated from the loaded surfaces.  Triangle 
volume by station may be computed between any types of surfaces, but also requires that a 
geometry file be loaded and an alignment for the stationing selected. 

Triangle Volume By Station Reports - The Steps 

Create the XML data file by selecting EVALUATION > VOLUMES > TRIANGLE VOLUME BY 

STATION….  Select the existing surface for “Original Surface” and the alternate SG surface for 
the “Design Surface”, select the horizontal alignment for stationing and then click [Apply]. 

 

When the Report Browser opens, Evaluation\TriangleVolumeByStation2.xsl is selected to 
get a Cut/Fill Triangle Volume By Station Report with totals of cut and fill at the bottom. 

 

Use FILE > SAVE AS… in the report browser to save the report as XLS File (*.xls). 
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Superelevation 

“The standard method of superelevation development for ODOT is rotation around the profile 
grade.  The profile grade is carried along the low side edge of travel.”, 2012 ODOT Highway 
Design Manual. 

 

Sections at key stations look like this: 

 

 

 

Runoff length = spiral length. 

Normal crown 

Super Runoff (P.S.) - 0%:2%  

Reverse Crown - 2% Shed Roof; Sta. where pivot point changes 

Full Super (P.S.C.) 

Prof. 

Gr.  

Prof. 

Gr.  

Prof. 

Gr.  

Prof. 

Gr.  

Pivot 

Pt.  

Pivot 

Pt.  

Pivot 

Pt.  

Pivot 

Pt.  
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The super runoff diagram shown above is from Figure 3-4 of 2012 English HDM.  The vertical axis 
of this diagram is %superelevation and the resulting superelevation control lines have a constant 
gradient.  A constant gradient for the %superelevation is what we are attempting to achieve 
under the AASHTO guidelines. 

The AASHTO Wizard in InRoads V8i creates the super control lines that meet the AASHTO 
guidelines for the constant super gradient. 

Superelevation Wizard - The Steps 

Prerequisites – Horizontal and Vertical alignments and original ground surface loaded.  
Corridor created and template drops assigned. 

Open the “Roadway Designer” dialog and the Superelevation Display window by selecting 
MODELER > ROADWAY DESIGNER… and clicking the [Superelevation Display] button.  Launch 
the AASHTO Wizard by selecting SUPERELEVATION > CREATE SUPERELEVATION WIZARD > 
AASHTO… 
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Maximum superelevation (‘e’ value) can be entered for each horizontal curve, if they were 
not already entered, using the [Rate Calculator…] button found on this dialog.  Remember, 
that because you’ve looked up the ‘e’ value in the ODOT Highway Design Manual, it is not 
necessary to use the calculator as anything other than an editor, where you will set the 
superelevation rate. 

The AASHTO Wizard opens with the Spiral Tangent Point at: set to “Zero Cross Slope”.  This 
is the correct setting for ODOT.  The P.S. is also known as the Super Runoff station, where 
the outside lanes are at 0% cross slope and the inside lanes are still at 2%.  Check the box to 
add “Non-linear Curve Length:” and enter 100 for the vertical curve length, and click 

[Next>]. 
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[Add…] a Section Definition for the station range you wish to control with superelevation.  
Set left and right range points to the travel lanes.  Shoulder Rollover Locks will be used to 
extend the super to the EP.  Pivot direction is set to “From Inside of curve” so that all will 
rotate about the low side edge of travel lane. 
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Click [Next>] and then [Finish]. 

Select SUPERELEVATION > APPLY SHOULDER ROLLOVER LOCK… 

Select each EP point, in turn, and click [Apply] to set the shoulder rollover lock to 0 % for 
both the high and low side.   
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You will see the lock applied in the cross section window of the Roadway Designer.  After 
setting the rollover locks on the EPs, [Close] the dialog. 

You can see the results of applying the superelevation control lines in the windows in the 
Roadway Designer, or you can create the surfaces, cut cross sections, and display the 
components.  The smooth superelevation gradient and vertical curves can be seen in the 
Superelevation Display Window.  The view below is adjusted to show only the following 
lines. 

Profile Window:  CL, TL_L, and TL_R 

Superelevation Display Window:  Section 1 CL-TL_L and Section 1 TL_R-CL 
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Surface Features to Survey Alignments 

Leica Viva TPS/GPS 

To perform true slope staking with the Leica instrument, you will need the linestrings 
corresponding to the surface features loaded onto the SD card in DBX format.  When 
following the steps below, it is recommended that you work in an empty model to make the 
selection of graphics easier.  Alignments of features should be created in a geometry project 
that contains the construction and/or RW centerlines. 

1. Using InRoads, first display all the continuous features from the design surface using 
<Ctrl>+left-click in the SURFACE > UPDATE 3-D/PLAN SURFACE DISPLAY dialog.  
These features would typically be named CL, TL, SGSh, and EP.  If the design surface 
moves in and out of cut, a ditch (Dch) feature or catch (SSC) would not be continuous 
from beginning to end of the project, so do not display those yet. 

2. In MicroStation, select all the displayed elements using a right-click “Select All”. 

3. Use FILE > IMPORT GEOMETRY…, FROM GRAPHICS tab, Type: “Horizontal and Vertical 

Alignment” to create alignments from the selected features.  Verify the Target 
Geometry Project and check “Use Tag Data” in the Attribute Tags section, then click 
[Apply].  The tag data will cause alignments to be created that have the same name as 
the feature. 

 

4. Now, display discontinuous features, like ditches and catches, one feature type and side 
at a time using the UPDATE 3-D/PLAN SURFACE DISPLAY dialog.  For example, select 
just Dch_R, or select all catches (cut or fill) on one side (see image below).  You may 
leave this dialog open until completely finished. 

5.  In MicroStation, select all the displayed elements using a right-click “Select All”. 
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6. In the still open IMPORT GEOMETRY…dialog, on the FROM GRAPHICS tab, with Type: set to 
“Horizontal and Vertical Alignment”, enter a name for the alignment you will create, 
check the box for “All Selected Elements Added to Single Alignment”, and uncheck “Use 
Tag Data”.  Click [Apply].  Repeat steps 4-6 for the other discontinuous features. 

 

7. Create DBX format files using InRoads.  Use FILE > TRANSLATORS > EXPORT LEICA 

DBX 1200…, choose the geometry project and make a selection set of alignments to be 
included in one Leica project.  The actual construction or RW centerline has to be in the 
selection set in order for offsets between template drops on curves to be staked 
correctly. 
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Importing and Exporting to LandXML 

LandXML is the preferred format for exchanging data between ODOT and contractors.  Both 
importing and exporting of alignments and surfaces are accomplished using the FILE > 

TRANSLATORS > LANDXML TRANSLATOR….  LandXML for surface information is typically stored 
in a separate XML file than alignment information.  The InRoads “LandXML” dialog combines 
importing of alignments and surfaces on one IMPORT tab, whereas exporting is separated by 
type of data and provides individual XML files for each data type.  LandXML files may be opened 
in any text editor; Notepad++ is set as the InRoads text editor. 

Exporting Geometry 

A geometry project must be loaded in InRoads.  Select the EXPORT ALIGNMENT tab from the 

“LandXML” dialog and choose the geometry project.  Use the column of buttons on the right 
side after alignments are selected and option check boxes are checked, with the exception 
of the [Filter…] button. 

1. Use the [Filter…] button to select mulitple alignments for export. 

 
2. Check “Include Active Children Only” to export only one vertical alignment for each 

horizontal alignment. 
3. Check “Include All Cogo Points” to export survey cogo points. 
4. Click the [Save As…] button, navigate to your export folder, and name the file. 
5. Click the [Preview] button to quickly open the file you just created using Notepad++ to 

verify the contents. 

The [Filter…] 
button is 

activated only 
when the cursor 

is in the 
Include: field. 
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The LandXML file contains the project name on line 3.  Lines 12 and 17 show that the 
contents are geometry: cogo points <CgPoints> and alignments <Alignments>. 
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Importing Geometry 

Select the IMPORT tab from the “LandXML” dialog and focus on the lower “Geometry” 
section.  The import can create a new geomtery project or add to the active geometry 
project.  It is safest to close any open InRoads geometry projects so that they are not 
inadvertently modified.  The project name, alignment name and style, as well as stationing 
are recorded in the XML.  If you check the options as shown below, you will create a new 
geometry project with alignments using the XML information. 

 

1. Use the [Browse…] button to navigate to the XML file and [Open] it. 
2. The [Preview] button can be used to verify that the XML file contains <Alignments> 

information and you can see the name of the geometry project also. 
3. Check the option “Use LandXML Project Name as Geometry Project Name” – if you 

leave this unchecked, the alignments and cogo points will be imported into the active 
geometry project. 

4. Click the [Apply] button. 

Exporting Surfaces 

“Importing and Exporting Surfaces Using LandXML Translator” on the EAST website in the 
InRoads Import/Export category of the Tips & Workflows has more information.   For the 
basics, a surface must be loaded in InRoads.  Select the EXPORT SURFACE tab from the 
“LandXML” dialog and select a surface to export.  <Ctrl>+left-click may be used to select 
multiple surfaces.  Use the column of buttons on the right side after surfaces are selected 
and option check boxes are checked.  If no options are checked, the result is an empty, 
named surface, so the idea is to check at least one option.  To export intelligence with a 
triangulated surface, you must include the features which have names and styles. 

Leave “Use 
LandXML 

Stationing” 
unchecked to use 

stationing 
recorded in the 

XML file. 

http://www.oregon.gov/ODOT/CS/east/Pages/TipsAndWorkflows.aspx
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1. Check “Include Triangles” to export the triangle vertices or points. 
2. Check “Include Features” to export breaklines with all their intelligence. 
3. Check “Include Non Triangulated Features” to export breaklines that are not 

triangulated in the surface. 
4. Click the [Save As…] button, navigate to your export folder, and name the file. 
5. Click the [Preview] button to quickly open the file you just created using Notepad++ to 

verify the contents. 

You need to 
check at least 
one option. 
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The LandXML file contains the surface name on line 8.  Line 10 begins the <Boundaries> 
block.  <Breaklines> are recorded after line 23, and the <Pnts> begin on line 423 (not 
shown). 

Importing Surfaces 

“Importing and Exporting Surfaces Using LandXML Translator” on the EAST website in the 
InRoads Import/Export category of the Tips & Workflows explains that InRoads must 
triangulate the surface after it is imported from LandXML.  It is safest to close any open 
InRoads surfaces so that they are not inadvertently overwritten.  Select the IMPORT tab 
from the “LandXML” dialog and focus on the upper “Surfaces” section.  If you check the 
options as shown below, you will create a new surface containing only features (no 
triangles) using the XML information. 

http://www.oregon.gov/ODOT/CS/east/Pages/TipsAndWorkflows.aspx
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1. Use the [Browse…] button to navigate to the XML file and [Open] it. 
2. The [Preview] button can be used to verify that the XML file contains <Surfaces> 

information and you can see the name of the surface also. 
3. Check the option “Include Triangle Points” – if you leave this unchecked, and there are 

no intelligent features in the LandXML file, your newly created surface will be empty. 
4. Click the [Apply] button. 
5. Use SURFACE > TRIANGULATE SURFACE… to create a triangulated surface. 

 

If the surface has 
no features, 

“Include Triangle 
Points” must be 

checked to 
import anything 

at all. 

Note: Zero 
triangles after 
import. 
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